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FireFamilyPlus Change Log 
 

FireFamilyPlus is used for analysis of fire 
danger indices and weather. It is a 
Windows program that combines the fire 
climatology and occurrence analysis 
capabilities of the PCFIRDAT, 
PCSEASON, FIRES, and CLIMATOLOGY 
programs into a single package with a 
graphical user interface. The current 
version of the program is Version 4.2 

(Build 24.19), released in September 2016.  The most significant changes in previous 
Version 4 releases are provided here. 

 

FireFamilyPlus Version 4.2 Build 24.19, Release September 2016. 
 
Major Items of Note in FireFamilyPlus 4.2 

 
• Corrected defects that caused the application to freeze on some 64-bit Windows 

7/8/10 Operating Systems with 64-bit MS Access drivers. 

• Added National Association of State Foresters (NASF) as a standard fire agency using 
State and County FIPS Codes as Region and Unit identifiers.  Source data: FAMWEB Data 
Warehouse.  For more details, see the online tutorial under the Help menu. 

• Corrected hourly values of fuel moistures (and subsequent NFDRS indices) computed 
using Fosberg methods.  Only 1-hour and 10-hour moistures are now computed from 
hourly observations; 100-hour, 1000-hour, live fuel moisture, and KBDI are computed 
only using the 1300 LST observation. 

• New FlamMap/FARSITE Weather Stream (*.wxs) exports, with gust or average winds 
have been added to Hourly Weather Export options. 

 
Minor Corrections and Enhancements 

 
• The template database, ffplus4.ffp has been updated to reflect recent WIMS 

station catalog data for active stations. Historical stations were removed, and 
USFS and FWS agency structures were updated to reflect various consolidations 
and additions.   

• Removed WRCC RAWS as a weather import option.  Functionality to ingest 
hourly wind gust data is now in standard FW13 format from the Western Region 
Climate Center (WRCC). 

• Enhanced Wind Rose graphics to use either 10-minute average or hourly gust 
values, or both. 

• Removed the FARSITE Version 3 option in Hourly Data Analysis FARSITE Exports. 
• Verbiage on PocketCard thresholds when percentile is < = 50 has been 

corrected. 
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• Stoplight on PocketCard has been removed. 
• Default values for local parameters Wind, Relative Humidity, and Temperature 

have been removed.  The user is required to make thoughtful entries. 
• Various defects in Interactive Batch (IAB) were corrected for more consistency 

between Batch and Interactive working sets.  
• Export Daily List to DL_Output table in database now works in batch mode. 
• Export Hourly Listing to HL_Output table in database now works as expected. 
• Various minor improvements have been made to FW9/FW13 and Generic 

Weather Import functions. 
• Various minor improvements have been made to Generic Fire Import functions, 

including adding new unit/subunits as needed. 
• Some rudimentary editing of USFS and DOI fire cause codes is available under 

Options > Statistical Cause Codes. 
• When Human is selected in Fire Analysis, you can further restrict fires by 

statistical cause by clicking on the “More” button.  
• Live Fuel Index values are correctly computed for a SIG. 
• When Daily is selected as the category in Event Locator, the actual value is 

displayed instead of TRUE. 
• When Hourly is selected as the category in Hourly Event Locator, the actual 

value is displayed instead of TRUE. 
 
FireFamilyPlus Version 4.1 Build 1520, Release March 22, 2013 
 
Major Items of Note in FireFamilyPlus 4.1 
 

o New Analysis Variables: 
 Fosberg Fire Weather Index (FFWI). 
 Live Fuel Index Based Live Herbaceous Fuel Moisture (FLI HerbFM - Experimental). 
 Live Fuel Index Based Live Woody Fuel Moisture (FLI WoodyFM - Experimental). 

o New Station Metadata: 
 WIMS Regular Scheduled Observation Time (RS) 
 NESDIS Station ID 
 WRCC Station ID 

o New NFDRS Processing Options to more closely align with WIMS Version 2: 
 Process NFDRS for both traditional "O" records and WIMS Version 2.0 "R" records 

with calculated State of Weather and WetFlag. These “R” records, for the RS 
time, are currently only available from WIMS via the PLST or Dashboard 
(FW9/FW13 Export Functions). 

 State of Weather can be estimated for the RS observation from hourly 
weather data as is done in the WIMS RAWS Gateway. Solar Radiation and 
Precipitation Thresholds can be modified as in WIMS. See Weather > Hourly 
Data Analysis > Calculated SOW/WetFlag. 

 WIMS Snow Flag logic in NFDR computations. (The Snow Flag is not yet 
transmitted externally but should be part of FW13 exports by spring of 2013.) 
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 Weather Data > Import and Export accommodate both FW9 and new FW13 Fire 
Weather Transfer Formats. FW13 adds Solar Radiation, Hourly Gust and Snow 
Flag. 

o TERM: A Term module has been added (Weather > Term). Term files can be 
initially populated from the Event Locator or manually. Term files can be 
imported and exported to text files. See Help Topic “Term.” 

• Fixes and Enhancements 
o Interactive Batch: More robust with better continuity between working set in 

Interactive and Classic modes. Reports in Interactive Batch can be edited and 
Copy, Cut, and Paste functions work as in the classic mode (Ctrl-C, Ctrl-X, Ctrl-V, 
respectively). Left clicking mouse in Graph Window now returns X and Y values as 
in Classic mode 

o Stats Graphs: Overlay Year(s) are now included in File > Export Graph Data. 
o Fire Occurrence Graphs: File > View Graph Data moved to Option > View 

Graph Data. 
o Fire Analysis Graphs: Lines thicker and line types differ for Fire-Day types.Fire 

Analysis Statistics: Sum of Squares information removed for easier reading. 
o Icons added to Toolbar for Daily List (L), Viewing Daily Observations (D), viewing All 

Observations (R), and viewing Fire Business Candidates (C). The View Observations 
windows can now be minimized while performing other FFP functions. 

o Data Count Report: Reformatted for easier reading. 
o Selecting Variables: The display order may be changed by clicking the Variables 

button. Available orders are: Alphabetical, Grouped (WX/NFDRS/CFDR), and ID (from 
ffpClimateOptions table). 

o Daily List: Results of Daily List can be directly exported into the current 
FireFamilyPlus database as a table. Table is always overwritten and named 
“DL_Output.” StationID or SIG name is included in each record. Memo field of first 
record in DL_Output holds the run parameters. 

o Batch\Run Options: Moved from Options to Batch on the main menu.. 
o NFDRS Calculator: Validates field limits and recalls last session. 
o Data->Import->Weather (FWX/FW9/FW13): If the importer detects a station ID from 

the Western Region Climate Center (WRCC), you have the option to load the data 
under the WRCC ID (current functionality) or the associated WIMS ID (new 
functionality). 

 
FireFamilyPlus Version 4.1 Beta Release, April 16, 2010 

• Added Features 
o A TERM module (Weather > Term) has been added. 

 The "Term" module duplicates the functionality of the Waiting Time functions in 
the RERAP program. 

 Existing Term Files may be imported and any number of Term Files can be stored 
in the database. Term files are associated with the Active Working Set 
(Station/Sig) when the file was created. 

 There is capability for extensive commenting in the term file. Term files in the 
database can be edited or deleted. 

 Finally, results from the Event Locator can be used to provide initial dates for a 
term file. See the Help Topic entitled "Term." 

• Fixes and Enhancements 
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o Interactive Batch: 
 User Variables are available. 
 Overlay Years are available. 
 Existing Dates in the Working Set are used instead of all available data; changes 

made to working sets in Interactive Batch are saved in the active working set. 
o Importing Multiple FW9 Files: The "Operation Failed, No Current Record" Error has 

been fixed. 
o Exporting Fires to Shapefiles: Fire Number not truncated in length; State Fire Cause 

Codes are now correct. (They were being remapped to DOI codes). 
o Live Fuel Moisture Calculations: Certain warm climate stations would not properly 

green up every year because X1000 not reset to FM1000. This has been corrected in 
CFNDRS.dll. 

 
FireFamilyPlus Version 4.0.2 Beta Release, December 1, 2008 

 
o Added FeaturesFiles can now be run in "Batch Mode." 

 To facilitate building batch jobs, FFP "Runs" can be saved in the active database. 
 Runs are numbered sequentially, and all the parameters within a run (station, 

SIG, data years, seasonal filters, overlay years, etc.) are saved. 
 Once in a database, these Runs can be used to: 

1. build batch jobs consisting of one or more saved runs, or 
2. reload identical settings and Run FFP in the "classic" mode. 

 When running a batch job, output can be to the screen (flying windows) or 
auto- saved to disk. 

o Files can also be run in "Interactive Batch Mode." 
 The interactive batch function allows you to "Run" any number of stations or 

SIG's at one time. 
 Every report for every variable in the database is generated for all years of 

data for each station. 
 Reports are tabs across the page top, stations and variables are expansion lists 

on the left side of the screen. 
 Icons allow you to change graph options, working set dates, overlay years, and 

fire- type selections to view. Changes are made to all reports and variables at 
once and redisplayed. 

• Fixes and Enhancements 
o Fire Occurrence Data: 

 The new BLM WFMI Fire Occurrence Export format (pchaffp) is supported along 
with the new NWCG Unit Identifiers for BLM, NPS, and BIA fire associations. 
More DOI "fire types" can now be imported. 

 A Generic Fire Import module supports Comma Separated Value (CSV) files for 
importing Custom agency fire data. More fields (e.g. county, latitude, longitude, 
etc.) can be included. The FPL format is no longer supported, but existing FPL 
files should be easily converted to CSV files. 

 Fires from the Working Set Fire Associations can be exported to an ESRI shape file. 
o Weather Data: 

 ALL Station information from WIMS as of April 2007 is in the default FFP database 
structure. Therefore, if you create a new database or upgrade from a Version 
3.0.5 FFP database you do not need to import catalogs. You may still wish to 
import a catalog to update information or when a new station has been added to 
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WIMS. 
 Generic weather import functionality allows flexibility to import data from 

alternate sources. It displays all of the weather observation elements from 
the FireFamilyPlus WXOBS data table and allows you to select columns that 
match elements in your alternate weather file. You can select the field 
delimiter and date/time formats. 

 WRCC RAWS: This functionality allows flexibility in importing hourly RAWS 
data from the Western Region Climate Center's (WRCC) Data Lister 
(http://www.raws.dri.edu/index.html). You can include wind gust and solar 
radiation information to the FFP database. 
 Note: Data imported in any manner from the WRCC will not have a STATE 

OF WEATHER (SOW) code. 
o Station Information and NFDRS: 

 The latitude and longitude are now GIS friendly. 
 When importing weather data, the WET FLAG data is now used and the WIMS 

snow cover logic has been implemented in FFP4. 
 Custom Yearly Initialization: To account for variable greenup dates and to 

better support the Canadian system, a Custom Yearly Initialization feature 
has been added to FFP. See Weather > Custom Yearly Init. 

 Brush Dormant Date: 
 To support areas where freezes do not generally occur, the capacity to allow 

shrubs to go into dormancy is supported by a new dormant flag and date. 
 If the flag is set, a valid date is entered in the live fuel moisture model (78 

models only), the vegetation state has cured, the observation date is greater 
than the dormant date, and the live fuel moisture model has dried the woody 
fuel moisture to its dormant value, the live vegetation state is put into a dormant 
state so that woody fuel moistures do not increase late in the fall with fall rains. 
This change was requested by Russ Gripp and allows FFP to better emulate user 
control in WIMS. 

 The default value for this field is unchecked. 
 A "use weighed 10-hr sticks" flag tells FFP to ignore weighed sticks and compute  the 

1- and 10-hour moisture by algorithm for the period of record. This allows for a 
consistent climatology for stations that may have 15 years of weighed sticks and 15 
years without. 

o Reports: 
 Expanded report headers include all current settings and station metadata. The 

ability to control report header information is included under the Options > 
Report Options menu item. You can select a delimiter (e.g. comma) for some 
reports to facilitate importing into other applications such as spread sheets or 
statistical analysis programs. 

 There is a FlamMap Fire Risk Export function. 
 Wind roses are available for hourly data (FW9 or WRCC). 

http://www.raws.dri.edu/index.html
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