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1. Introduction

FireFamilyPlus (FFP) is an agency independent Windows desktop application for
summarizing and analyzing historical daily fire weather observations and computing fire
danger indices based on the National Fire Danger Rating System (NFDRS) or the Canadian
Fire Danger Rating System (CFDRS). Fire occurrence data can also be analyzed and cross-
referenced with weather data to help determine critical levels of fire danger for staffing and
other fire management activities

FireFamilyPlus supports the spectrum of fire weather/fire danger/fire climate/fire occurrence
analysis tools required by fire managers to successfully use the NFDRS which is mandated
for use in fire preparedness by all Federal and most State agencies. The NFDRS is
operationally run with F&AM's Weather Information Management System (WIMS).

It is the computational and analysis cornerstone for Advanced Fire Danger Rating (at
NAFRI) and S-491 (Intermediate Fire Danger Rating) and provides fire weather/danger
climate summaries for techniques taught at S-495. (Geospatial Fire Analysis Interpretation
and Application). It generates the Fire Danger Rating Pocket Cards required by the 30-Mile
Abatement Plan and supports the Predictive Services functions at all the Geographic
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Coordination Centers. Updates have been supported by the U.S. Forest Service Fire and
Aviation Management and the Rocky Mountain Research Station.

Major Items of Note in FireFamilyPlus 4.2

e Corrected defects that caused the application to freeze on some 64-bit Windows 7/8/10
Operating Systems with 64-bit MS Access drivers.

e Added National Association of State Foresters (NASF) as a standard fire agency using
State and County FIPS Codes as Region and Unit identifiers. Source data: FAMWEB
Data Warehouse. For more details, see the online tutorial under the Help menu.

e Corrected hourly values of fuel moistures (and subsequent NFDRS indices) computed
using Fosberg methods. Only 1-hour and 10-hour moistures are now computed from
hourly observations; 100-hour, 1000-hour, live fuel moisture, and KBDI are computed
only using the 1300 LST observation.

e New FlamMap/FARSITE Weather Stream (*.wxs) exports, with gust or average winds
have been added to Hourly Weather Export options.

Minor Corrections and Enhancements

e The template database, ffplus4.ffp has been updated to reflect recent WIMS station
catalog data for active stations. Historical stations were removed, and USFS and FWS
agency structures were updated to reflect various consolidations and additions.

e Removed WRCC RAWS as a weather import option. Functionality to ingest hourly
wind gust data is now in standard FW13 format from the Western Region Climate Center
(WRCC).

e Enhanced Wind Rose graphics to use either 10-minute average or hourly gust values, or
both.

e Removed the FARSITE Version 3 option in Hourly Data Analysis FARSITE Exports.
e Verbiage on PocketCard thresholds when percentile is < = 50 has been corrected.
e Stoplight on PocketCard has been removed.

e Default values for local parameters Wind, Relative Humidity, and Temperature have
been removed. The user is required to make thoughtful entries.

e Various defects in Interactive Batch (IAB) were corrected for more consistency between
Batch and Interactive working sets.

e Export Daily List to DL_Output table in database now works in batch mode.
e Export Hourly Listing to HL_Output table in database now works as expected.

e Various minor improvements have been made to FW9/FW13 and Generic Weather
Import functions.

e Various minor improvements have been made to Generic Fire Import functions, including
adding new unit/subunits as needed.

e Some rudimentary editing of USFS and DOI fire cause codes is available under Options
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> Statistical Cause Codes.

e When Human is selected in Fire Analysis, you can further restrict fires by statistical
cause by clicking on the “More” button.

e Live Fuel Index values are correctly computed for a SIG.

e When Daily is selected as the category in Event Locator, the actual value is displayed
instead of TRUE.

e When Hourly is selected as the category in Hourly Event Locator, the actual value is
displayed instead of TRUE.

2. System Requirements

Operating System Windows through Windows 10

Memory 64Mb.

Storage 100 Mb. Will increase with large databases.
Display Minimum 1024 x 768 pixels, 264K (16-bit) colors.
Help The online help is a Compiled HTML Help file

and requires Internet Explorer. The file, ffp4.chm
will be updated from time to time.

License There are no licensing requirements.

Data Requirements | FireFamilyPlus comes with a sample database
and will automatically upgrade older databases to
the Version 4.2 database structure. The Acquiring
Data topic in the program’s online Help describes
sources of data FFP will import for analysis. The
Importing Data topic describes methods for
importing data files.

3. Download

You can download the latest FireFamilyPlus 4.2 installation program
(FireFamilyPlus42.msi, 22.6 MB from the FireFamilyPlus Downloads page. The MSI file
may be contained in a Zip file (22.0 MB). If this is the case you will need to unzip or extract
the MSI file. Other FireFamilyPlus documents, and supporting materials are also available at

FireLab.org.

4, Installation

If you have FireFamilyPlus version 4.1 already installed, you do not have to uninstall it from
your computer, although you may.

FireFamilyPlus 4.2 installs to c:\WorkSpace\FireFamilyPlus42 to avoid conflict with
security settings in Program Files. Depending on your computer security settings, you may
need administrative rights. USDA Forest Service computers may need to use Install Elevated
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methods.

1. Once you have downloaded the installation
program, run it by:

e clicking Start and Run, browse to locate
FireFamilyPlus42.msi, and select OK, or

e using My Computer or Windows
Explorer ® to locate the file and double-
click on the name or icon.

USDA Forest Service computers may need to use
Install Elevated methods. Right click on the
installation file and select “Install Elevated” as

o i
i5 FireFamilyPlus42.msi
ﬁ! FireFamilyPlus42_ws2015a.r
= gb_rstime.fwl3
=) gb_rstimel fwl3
&4 MASF State Data Extract W

Install

Repair

Uninstall

Troubleshoot compatibility

| RAWS_Uniqueness_Index.k

Ilu{ta Il Elevated

Ea
= RAWS Unigueness_Index.k
L2l untitled.mdb
[£1] untitled4l.mdb
(£l untitled41tod2-custom.md
[£l] untitled41tod2-no-custom
d: 8/18/2016 9:50 AM
e 22.6 MB Offli

o0 when at cdse, ake

Tue

Open with...

WinZip

Always available offline
Restore previous versions

S5end to

Cut
Copy

Create shortcut

. nd Rachel Cook put together an { Delete
ShOWﬂ In Step 2 Rename
Properties
—
3. 4.

5]

The publisher could not be verified. Are you sure you want to
run this software?

Open File - Security Warning

CrhFireFamilyPlus42.msi

Unknown Publisher

Mame:
Publigher:

Type: Windows Installer Package

From: D:\FireFamilyPlusd2.msi

[ Run ] [ Cancel

Thig file does not have a valid digital signature that verifies itz
publisher. You should only run software from publishers you trust.
How can | decide what software to un?

|_!'5_|
.

If you Install Elevated, a Power
Broker dialog will open and request
justification. Enter “FireFamilyPlus”
in the dialog box and click OK.
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5. | 6.
r r Y
4] FireFamily Plus 4.2 - InstallShield Wizard (S 141 FirFamity Plus 42 - InstalShield Wizard =)
Welcome to the InstallShield Wizard for Destination Folder
FireFamily Plus 4.2 Click Mext to instal to this folder, or dick Change to install to a different folder,
The Installshield(R) Wizard will install FireFamily Plus 4.2 on Install FireFamiy Plus 4.2 to:
your computer, To continue, dick Next. C:\Workspace FireFamilyPlus42\ m
I
H
|
WARNING: This program is protected by copyright law and
international treaties.
[l
[l
|| InstzliShield
N < Back Next = ] Cancel ] | < Back Next > ] [ Cancel ]
———— r——;
7. 8.
r - : ™
1% FireFamily Plus 4.2 - InstallShield Wizard 1) FireFamily Plus 42 - InstaliShield Wizard =
Ready to Install the Program InstaliShield Wizard Completed

The wizard is ready to begin installation.

Click Install to begin the installation.

If you want to review or change any of your installation settings, dick Back. Click Cancel to
exit the wizard.

|| InstallShield

< Back [ '@'Insmll JI Cancel

The InstalShield Wizard has successfully nstalled FireFamily
Plus 4.2. Click Finish to exit the wizard.

5. Starting FireFamilyPlus 4.2

FireFamilyPlus 4.2

The FireFamilyPlus4.1 installation program should create a desktop icon. You can start the
program via Start->Programs-> FireFamilyPlus 4.2->FireFamilyPlus 4.2. You can use
standard methods to create a shortcut to the application file, “fireplus.exe” if one is not

placed on your desktop during the installation.

J FireFamilyPlus 4.2

- B FireFampily Plus 4.2 2
BB NFDRSElculator

Jﬁ Uninstall FireFamily Plus 4.2

If you have a previous version of FireFamilyPlus installed on your computer, the last database
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used will likely be opened and upgraded when you start Version 4.2.

Version 4.2 includes a sample database, C:\WorkSpace\FireFamilyPlus42\ffplus4. The
database contains:

L

Daily weather observations from Moose Creek, 1D (101028) from 1996 to 2008
b. Hourly observations, with wind gust and solar radiation from Moose Creek
for 2008 (May through July).
c. Fire occurrence records from USFS, Region 1, Nez Perce NF (17) for 1996
to 2007, associated with Moose Creek.
. Daily weather observations from Libby, MT (240107) from 1996 to 2007.
e. Fire occurrence records from USFS, Region 1, Kootenai NF (14) for 1996
to 2007, associated with Libby.

The template database from which FireFamilyPlus creates new databases has minor updates
that include weather stations recently added to WIM and updates in some Forest Service fire
occurrence associations that reflect recent Forest consolidations, particularly in Region 1
(Northern Rockies).

5.1 Possible FireFamilyPlus 4.2 Compatibility Issue

There should be no database compatibly issues between previous versions but if you get an
error after upgrade process, try closing and reopening the database.

FireFamilyPlus 4.1 and 4.2 share the same “recent file” registry and on rare occasions, if there
is a problem upgrading to the 4.1 database, you will get “Stuck” opening the same file every
time you start FireFamilyPlus (4.1 or 4.2). To get past this you must delete the files list in the
Registry. This done by Start->Run->Regedit -> OK as shown below:

=== Typethe name of a pregram, folder, document, or Internet
resource, and Windows will open it for you.

Open: m -

|| Browse... |

Once the Registry Editor has opened, navigate to:
HKEY_CURRENT_USER >Software >FireFamilyPlus4 >FireFamilyPlus >Recent File List
then right click on Filel in the Name column and select delete. There may be up to four recent

files here. You should probably delete them all. Close the Registry Editor and restart
FireFamilyPlus and do File->Open to select a different database, or File->New to create a new
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database.

@’ Registry Editor

File Edit View Favorites Help
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e Cpp v‘en : ] F:\ffp_testing_july\north_dakota\tananka_prairie....
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Control Panc! Modify... CA\WorkSpace’ FireFamilyPlusi2\ffplusd.mdb
- Madify Binary Data...
Environment
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Keyboard Layout
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ename

m
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S BN ESL CE. Lpp. 4
s )l ESRI
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: FireFamily Plus

: . Settings
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6. Uninstalling FireFamilyPlus

Note: Uninstalling FireFamilyPlus will remove all distribution files from the installation
directory, including the sample database ffplus4.mdb. If you need ffplus4.mdb you should
make a copy of it prior to uninstalling FireFamilyPlus. Uninstalling will not remove any
database files you may have created in this directory.

You may remove FireFamilyPlus using the standard Window Add/Remove Programs:

e Access the Control Panel,

e click the Add/Remove Programs icon,

e |ocate the FireFamilyPlus 4.x entry in the program list and click Remove (Windows
2000 and later).

USDA Forest Service users who used Install Elevated methods may need to use PowerBroker to
uninstall FireFamilyPlus. This is accomplished by

Start->All Programs->PowerBroker->PowerBroker — Uninstall or Change a Program

. PowerBroker
#3 PowerBroker - Metwork Centrol Pan
aéa PowerBroker - Printer Control Panel
[@ PowerfEpker - Uninstall or Change a Program
T !
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7. Support

Technical Support

The first level of technical support is provided through your local support channels. Please
review our FAQs and Known Bugs pages prior to contacting the Help Desk.

The second level of technical support is provided by the USDA Forest Service Fire and
Aviation Interagency Incident Applications (11A) HelpDesk.

Phone: (866) 224-7677 or (616) 323-1667,

Fax: (616) 323-1665

E-mail: IIA-Helpdesk@fs.fed.us

Website: https://iia-hd.peckham-enclave.us/ (link is external)

The 1A HelpDesk is available for help with software issues only and cannot answer fire
behavior questions.

Training Material

There is currently no single FireFamilyPlus course but several Tech Tips and self-study
modules are available at www.firemodels.org and more are being developed.

User’s Guide

The FireFamilyPlus User's Guide covers all aspects of the program operation and is available
in Adobe ® PDF format. The document for Version 4 is currently under development and
draft versions are available.
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