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Preface

Welcome to the FireFamily Plus (FFP) Version 4 User’s Guide, the first 
update to the FireFamily Plus Version 2 User’s Guide (Bradshaw and 
McCormick, 2000). FFP is software for summarizing and analyzing daily 
weather observations and computing fire danger indices based on the United 
States National Fire Danger Rating System (NFDRS). It will also produce 
Fire Danger Indices for the Canadian Fire Danger Rating System (CFDRS). 
The guide provides details on obtaining historical fire weather and occurrence 
data, importing those data into FFP, and working with the analysis capabilities 
of the program.

In its minimal functionality, FFP provides climatological values of Fire 
Danger Indices used to establish climatological breakpoints for fire weather 
stations in the Weather Information Management System (WIMS). 

Because FFP is based on an integrated fire weather/fire occurrence database, 
it has analysis tools to evaluate statistical relationships among weather 
stations/fuel models/indices, and the fire business they represent. It has a 
flexible analysis and graphing environment, including station grouping, 
variable period groups (daily, weekly, and so forth), overlay years and fire 
activity. FFP will generate Pocket Cards for Firefighter Safety and supports 
many of the climatology data requirements of Fire Behavior Analysts making 
long-range fire growth assessments using Rerap and fire growth projections 
using Farsite.

We hope you find this guide friendly and easy-to-use. If you have any 
questions, comments, or concerns about this guide, please contact:

USDA Forest Service
National Fire and Aviation Management Information Systems Team
3833 S. Development Avenue
Boise, ID 83705

(800) 253-5559

You can email us at:

fire_help@fs.fed.us

To obtain a copy of the FireFamily Plus User’s Guide

1 Start your Internet browser.

2 In the address box, type http://firefamilyplus.firemodels.org and then 
press ENTER.

3 Click Downloads, and then click FireFamily Plus User’s Guide.
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What’s new
Version 4.0 is the upgrade to version 3.0 that was released in May 2007. 
We've incorporated many of the suggestions from the user community and 
continue modifications that allow the program to flow better. All reported 
bugs from version 3.0 have been corrected.

The FireFamily Plus version 4.0 (FFP4) database structure differs 
significantly from FireFamily Plus version 3.0 (FFP3) to support the batch 
and run saving operations. When a 3.x database is opened FFP4 will attempt 
to upgrade it to 4.0 and will save a copy in the 3.x format. To be safe, you 
should backup your important databases before using FFP4.

The following specific improvements have been made

Batch Modes

• FFP 4.0 performs in the same manner as previous versions but introduces 
a “batch mode.” To facilitate building batch jobs, FFP “Runs” can be 
saved in the active database. Runs are numbered sequentially. All the 
parameters in the Run (station, SIG, data years, seasonal filters, overlay 
years, etc.) are saved. Once in the database these Runs can be used to 1) 
build batch jobs consisting of one or more saved runs, or 2) to reload 
identical settings. When running a batch job, output can be to the screen 
(flying windows) or auto-saved to disk.

Interactive Batch

• The interactive batch function allows you to “Run” any number of 
stations or Special Interest Group (SIG) at one time. Every report for 
every variable in the database is generated for all years of data for each 
station. Reports are tabs across the page top. Stations and variables are 
given in expansion lists on the left side of the screen. Icons allow you to 
change graph options, working set dates, overlay years, and fire-type 
selections. Changes are made to all reports and variables at once and re-
displayed.

Fire Occurrence Data

• The new Bureau of Land Management (BLM) Wildland Fire 
Management Information (WFMI) Fire Occurrence Export format 
(pchaffp) is supported along with the new NWCG Unit Identifier's for 
BLM, National Park Service (NPS), and Bureau of Indian Affairs (BIA) 
fire associations. Also when importing Department of Interior (DOI) 
fires, additional “fire types” can now be imported.

• A Generic Fire Import module supports Comma Separated Value (.CSV) 
files for importing Custom agency fire data.   More fields (e.g. county, 
latitude, longitude, etc.) can be included. The Fire PLanning (FPL) format 
is no longer supported but existing FPL files are easily converted to.CSV 
files.

• Fires from the Working Set Fire Associations can be exported to an ESRI 
shapefile (provided the fire report contains latitude and longitude).
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Weather Data

• ALL Station information from Weather Information Management System 
(WIMS) as of April 2007 is in the default FFP database structure. That 
means if you create a new database or upgrade from a Version 3.0.5 FFP 
database you do not need to import station catalogs. You may however, 
still wish to import a catalog to update information or when a new station 
has been added to WIMS.

• Generic Wx Import: This functionality allows flexibility to import data 
from alternate sources. It displays all of the weather observation elements 
from the FireFamily Plus WXOBS data table and allows you to select 
columns that match elements in your alternate weather file. You can select 
the field delimiter and date/time formats. 

• Western Region Climate Center (WRCC) Remote Automated Weather 
Station (RAWS): This functionality allows flexibility in importing hourly 
RAWS data from the Western Region Climate Center's data lister 
(www.raws.dri.edu). You can include wind gust and solar radiation 
information to the FFP database.

Note: Data imported in any manner from the WRCC WILL NOT have a 
STATE of WEATHER (SOW) code.

Station information and NFDRS

• The latitude and longitude are now GIS friendly.

• When importing weather data, the WET FLAG data is now used and the 
WIMS snow cover logic has been implemented in FFP 4.

• Custom Yearly Initialization: To account for variable greenup dates and to 
better support the Canadian system a Custom Yearly Initialization feature 
has been added to FFP4. (See Weather -> Custom Yearly Init).

• Brush Dormant Date: To support areas where freezes do not generally 
occur, the capacity to allow shrubs to go into dormancy is supported by a 
new Use Brush Dormant Date box. This was requested by Russ Gripp 
and allows FFP to better emulate user control in WIMS. The default value 
for this field is unchecked. If the following conditions are met, the brush 
dormant date will apply:

•         the brush dormant date is selected.

•         a valid date entered.

•         the vegetation has cured.

•         the observation date is greater than the dormant date.

•         the live fuel moisture model has dried the woody fuel moisture to it's

•         dormant value.

•         the live vegetation state is put into a dormant state so that woody fuel

              moistures do not increase late in the fall with fall rains.

D R
 A

 F T
iii June, 2009



FireFamily Plus User’s Guide Preface
• If selected, a “Use-Weighed 10-HR Sticks” check box enables FFP to 
ignore weighed sticks and compute the 1- and 10-hour moisture by 
algorithm for the period of record. This allows for a consistent 
climatology for stations that may have some years of weighed sticks and 
some years without.

Reports

• Expanded report headers include all current settings and station metadata. 
The ability to control report header information is included under the 
Options->Report Options menu item. Also you can select a delimeter 
(e.g. comma) for some reports to facilitate importing into other 
applications such as spreadsheets or statistical analysis programs.

• There is a FlamMap Fire Risk Export function.

• Winds: Wind roses are available for hourly data.

Windows 2000, Windows XP, and Windows VISTA are registered trademarks of Microsoft Corporation. This guide employs many 
styles, conventions, and guidelines established in “The Microsoft Manual of Style for Technical Publications.”
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Chapter 1.  About this guide

This guide explains how to use FireFamily Plus version 4. It contains 
information about how to create a new database by importing station catalogs 
and weather and fire data, how to define an active working set, how to 
generate reports and pocket cards, and how to perform fire analysis and 
projection functions.

Before you begin
Before using FireFamily Plus software, you must feel confident that:

• You are familiar with your personal computer and function keys and 
understand basic computer concepts.

• You are familiar with Microsoft Operating Systems (Windows 2000, 
Windows XP, or Vista).

• You have a basic understanding of fire weather observations, fire danger 
concepts, and terminology.

How to use this guide
You do not need to read the entire FireFamily Plus User's Guide to complete a 
specific task. Once you understand how to start FireFamily Plus, you can 
quickly locate commonly used tasks by reviewing the "Contents" in the front 
of this guide.

This guide is divided into chapters.   The chapter title appears at the top of 
each page. At the beginning of each chapter you will find an overview of the 
topics explained. Where appropriate, diagrams are shown immediately 
following each task.

Chapter 1, "About this guide," introduces the FireFamily Plus User's Guide 
and explains how to use the guide.

Chapter 2, "Introducing FireFamily Plus," explains important terms and 
concepts, how to install FireFamily Plus, and introduces the FireFamily Plus 
toolbar and working set screen elements.

Chapter 3, "Working with a FireFamily Plus database," explains how to create 
and manage a database.

Chapter 4, "Importing data," explains how to import station catalogs, fire 
weather, and fire occurrence data as well as how to define custom agencies 
and how to work with user variables.

Chapter 5, "Working with data in FireFamily Plus," explains how to define an 
active working set, how to work with station metadata and special interest 
groups (SIGs).

Chapter 6, "Working with reports and graphs," explains how to review 
weather data, generate reports, work with overlays and graphs, season reports, 
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FireFamily Plus User’s Guide Chapter 1. About this guide
weather and fire occurrence data, and how to use the event locator and the 
NFDRS calculator.

Chapter 7, "Working with fire analysis tools," explains how to perform and 
review cumulative and probability analyses, how to work with decision 
points, and how to use the fire business candidates list.

Chapter 8, "Generating a pocket card," explains how to generate a pocket card 
that identifies years of interest for comparison. It also includes instructions for 
changing the background pattern and saving pocket card graphs. 

Chapter 9, "Working with fire danger projections," explains how to use fire 
weather records generated from climatological percentiles, how to review the 
active working set, and how to generate fire danger projections, reports and 
graphs.

Chapter 10, "Performing hourly data analysis," explains how to generate and 
view hourly listings and diurnal graphs, and how to export hourly data to 
FarSite. This chapter also explains how to use the hourly event locator and 
Nelson Dead Fuel Moisture Model.

Chapter 11, "Batch functions," discusses saving runs and managing batch 
lists.

Chapter 12, "Interactive batch," explains how to work with the new 
interactive batch function.

Chapter 13, "Exporting data," explains how to export SIGs and station 
metadata, fire data and weather observation records.

Appendix A, "Retrieving NIFMID data using KCFAST," explains how to 
access KCFAST, how to retrieve weather, fire occurrence and station catalog 
data, and how to download and save files using the ftp site.

Appendix B, "Using FireFamily Plus with RERAP," explains how to generate 
a percentile weather report.

Appendix C, "Editing unknown fire reporting units," explains how to work 
with "unknown" units and subunits.

Appendix D, "Weather data sources and attributes,” explains how to obtain 
sources of weather data and discusses their characteristics.

References are arranged alphabetically and contain sources of information 
used to complete this guide.

Conventions
The following conventions are used within this guide:

• Labels for buttons, dialog boxes, screens, files, and other and hard label 
keys appear in bold. For example, the second step in a procedure might 
state:

On the Set Fire Associations dialog box, click the USFS tab.
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Topics of special interest or hints that will help you perform a specific task are 
shown with a line before and after the text. The text appears in italic type. For 
example:

Although you can delete and then recreate a SIG, you cannot change its 
name once you save it.
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Chapter 2.  Introducing FireFamily Plus

This chapter explains how to use FireFamily Plus. Topics include:

• Installing FireFamily Plus.
• Terms and concepts.
• Screen terminology
• FireFamily Plus toolbar
• Working screen set elements

Installing FireFamily Plus
This section outlines the basic instructions to install the FireFamily Plus 
program for Windows 2000, Windows XP, and Vista operating environments. 
The “FireFamily Plus Version 4.0 Release Notice” contains the information 
and instructions you need to choose the correct installation package.

To download the FireFamily Plus installation file

1 Start your Internet browser.

2 In the address box, type http://firefamilyplus.firemodels.org, and click 
on the Downloads link.

3 You can obtain the Relase Notice in two ways:  1) from the Downloads 
page, click on firefamilyplus4_relase_note.pdf in the first line of the 
table, or 2) go to Release Notice at the left side of the screen under 
Software, and click on Relase Notice under FireFamily Plus 4.0.

4 Review the Release Notice to determine the appropriate file needed to 
install FireFamily Plus version 4.0.The release notice also identifies the 
system and data requirements, sample database, and includes “uninstall” 
instructions. Review the entire notice carefully for complete instructions.

5 Double-click on the appropriate installation file, and then save it in the 
folder of your choice.

For a new installation, click on ffp4setup.msi

The following diagram shows the FireFamily Plus Downloads page on 
wwwfiremodels.org. The arrow points to the FireFamily Plus Release Notice.D R
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.

FireFamily Plus 4.0 installation notes

• You do NOT need to, nor should you uninstall FFP 3.0.5.

• BACKUP YOUR VERSION 3.0.5 DATABASES.

• The FFP 4 database structure is significantly different from FFP 3 to 
support the batch and run saving operations. When a 3.x database is 
opened FFP 4 will attempt to upgrade it to 4.0 and will save a version in a 
3x format with a _v3 added to the file name (not extension). But to be 
safe, you should backup your important databases before using FFP 4.0.   

• If you have a previous Alpha or Beta version of 4.0, you will need to 
uninstall it.

• FFP 4.0 should NOT require administrative privileges.

• Execute the installation file: ffp_setup.msi (~ 7 MB)

• FFP 4.0 will install to: Program Files/FireFamily Plus 4

• FFP does NOT create a desktop shortcut.
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To install FireFamily Plus

1 From your personal computer, double-click the self-extracting FireFamily 
Plus installation file (ffp4setup.msi).

2 Complete the installation process as instructed on your screen and 
described below.

The Welcome dialog box shown below opens initially. Click Next to continue 
the installation process.

The Select Installation Folder dialog box allows you to choose an 
installation location. Select the Target Folder as shown or use the browse 
button to select an alternate location. 

3 Click Next to continue the installation process.

4 You will see a dialog box similar to the one shown. Select the Everyone 
radio button as shown. 
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5 Click Next to confirm and continue installation of FireFamily Plus.
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The following progress bar indicates that installation is proceeding.
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The next dialog box indicates that the installation process is complete.
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6 Click Close to proceed. 

To start FireFamily Plus

1 Start FireFamily Plus4 by Start -> Programs -> FireFamilyPlus4 or by 
creating a desktop shortcut. If FFP3 is installed, FireFamily Plus4 will 
automatically open the most recently used FFP 3.0.5 database and attempt 
to upgrade it. 

Terms and concepts
This section identifies some of the screens, toolbars, and menus that you will 
be using in FireFamily Plus. If you are not already familiar with Windows-
based programs, become familiar with these terms and concepts before 
proceeding with the remaining chapters in this guide.

Screen terminology
The following diagram outlines many of the elements available on the 
Windows-based FireFamily Plus screen

Screen elements and toolbars unique to a specific module are introduced 
within the corresponding chapter.
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FireFamily Plus toolbar

The following diagram shows the expanded FireFamily Plus toolbar. This 
toolbar allows you to quickly access many FireFamily Plus functions by 
simply clicking a button.
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Working set screen elements

The following diagram shows the new FireFamily Plus Working Set screen.

D R
 A

 F T
2.9 June, 2009



FireFamily Plus User’s Guide Chapter 2. Introducing FireFamily Plus
D R
 A

 F T
June, 2009 2.10



Chapter 3.  Working with a FireFamily Plus 
database

This chapter explains how to work with a database in FireFamily Plus. Topics 
include:

• Opening the sample database.
• Creating a new database.
• Managing a database

Opening the sample database
FireFamily Plus is shipped with a sample database “ffplus4.mbd.” It contains 
station catalogs “101028” and “240107” and the Special Interest Group 
“Sample SIG,” along with associated weather and fires data.

For more information about Special Interest Groups, see “Working with 
Special Interest Groups” in Chapter 5, “Working with data in FireFamily Plus.”
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To open the sample database

1 On the File menu, click on the FFP4 database and click Open.

2 Select ffplus4.mdb, the FireFamily Plus4 database, and click Open.

The following figure shows the sample database “ffplus4” as it first appears 
on your screen.

3 Close the file. File -> Close.

For more information about specific elements on this screen, see Chapter 2, 
“Introducing FireFamily Plus.”

Creating a new database
This section explains how to create a FireFamily Plus database that you will 
populate with station catalogs and imported historical and fire occurrence 
data. Topics include:
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• Retrieving and downloading data from Kansas City Fire Access Software 
(KCFAST).

• Retrieving and downloading fire and weather data from FAMWEB 
(National Fire and Aviation Management Web Applications).

• How to obtain your station catalogs, fire weather, and fire occurrence data 
(for more detailed instructions on importing data, see Chapter 4).

You can create as many databases as required to meet your needs. Although 
you can keep many databases open at the same time during your FireFamily 
Plus session, only one database is “active” at any given time.

To create and save a new database

1 On the File menu, click New.

2 In the File name box, type the name of your new database, and then click 
Save.

3 Enter a meaningful description (up to 50 characters in length).

The following diagram shows the New FireFamily Plus Database dialog 
box.
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Retrieving and downloading data from KCFAST
To begin, you must access KCFAST from the Fire and Aviation Management 
website at: http://fam.nwcg.gov/fam-web/

First, you will need to retrieve historical fire weather data, fire occurrence 
data, and station catalog information.  Next, download the files from the fpt 
site to your computer.

For complete instructions about using KCFAST, see Appendix A, “Retrieving 
National Interagency Fire Management Integrated Database (NIFMID) data 
using KCFAST,” at the back of this guide.  You will need a user name and 
password to access the data.

To retrieve historical fire weather data

1 From the KCFAST Main Menu, click Weather. 

2 Click Data Extract, and then click Historical.

3 Type the Station ID,  and then Begin and End Date Range.

4 Click Raw Datafile - 1972 Data Format.

To use diurnal functions or create files to support FARSITE, select Raw 
Datafile - 1972 Data Format, *.FW9. (See “Importing Fire Weather Data” 
in Chapter 4).

5 Select the E-mail notification option of your choice, click Submit, then 
write down the file name.

To retrieve US Forest Service fire occurrence data

1 From the KCFAST Main Menu, click Fire.

2 Click Standard Extract.

3 Type the two digit Region and two digit Forest numbers.

4 Type the Begin Year and End Year under Date Range.

5 Click NFMAS - PCHA (PC Historical Analysis).

6 Click Raw Datafile.

7 Select the E-mail notification option of your choice, click Submit, then 
write down the file name.

To retrieve station catalog information for a single station

As of April, 2007, station information is included in the default FFP database 
structure. If you create a new database or upgrade from a Version 3.0.5 FFP 
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database, you do not need to import station catalogs. You may still import a 
station catalog to update information or if a new station has been added. 

1 From the KCFAST Main Menu, click Weather.

2 Click Station Catalog, and then click Station Information.

3 Click BY SINGLE STATION, and then type the desired Station ID.

4 Click Send file to FTP site.

5 Select the E-mail notification option of your choice, click Submit, then 
write down the file name.

To download a file from ftp2.fs.fed.us

1 Start your Internet browser. 

2 In the address box, type ftp://ftp2.fs.fed.us/incoming/wo_fam then press 
ENTER.

3 Right-click the file name of your choice, click Copy to folder, then 
double-click the folder of your choice. (See Chapter 4 for more 
information on importing data).

Retrieving and downloading fire and weather data from 
FAMWEB (National Fire and Aviation Management Web 
Applications)

The National Fire and Aviation Management Web Applications website 
provides another source of historical fire weather observations.  This site is 
organized by state and includes federal fires and weather observations from 
WIMS users. Observations are updated once a year for the previous year and 
for all historical data.

To obtain weather data and Station Catalogs from FAMWEB

1 Go to the FAMWEB website at http://fam.nwcg.gov/fam-web/
weatherfirecd.

2 Select a state from the list at the left side of the page.D R
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3 Right-click on the file you would like to download.
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4 Select Save File. (Save Link As)

5 Save weather files as .fwx files.  D R
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6 You can import these .fwx files into FireFamily Plus as discussed in 
Chapter 4

7 Station Catalog files can be downloaded and saved as a text file in a 
similar manner.

To obtain fire occurrence files from FAMWEB

1 Click Fire Occurrence Files at the top of the page.

2 Select an agency from the list provided.
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3 Right-click on the file you would like to download.

4 Save the file.  

5 You can import the file into FireFamily Plus as discussed in Chapter 4.

Managing a database

To compact the database

1 On the Data menu, click Compact.

2 Click OK.

The following diagram shows the Compact Database dialog box. From here, 
you can remove unused storage for records deleted from your database.
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How to import data
This chapter explains how to import files to use in FireFamily Plus. Topics 
include:

• Importing station catalogs.
• Creating a new station.
• Importing fire weather data.
• Importing federal fire occurrence data.
• Defining custom agencies and importing fire occurrence data.
• User variables.

Importing station catalogs

Station information is now included in the default FFP database structure. 
Therefore, if you create a new database or upgrade from an FFP version 3.0.5 
database, you do not need to import the catalogs. You may still wish to import 
a station catalog to update information or when a new station has been added.

After saving the historical fire weather data, fire occurrence data, and the 
station catalog information on your personal computer, you can import the 
information into the newly created database.

To import a station catalog

Station catalog information as of April 2007, is included in the default 
FireFamily Plus database structure. This means that if you create a new 
database or upgrade from a Version 3.0.5 database, you do not need to import 
the catalogs. You may still wish to import a catalog to update information or if 
a new station has been added to the network.
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Refer to Chapter 3 for additional information on obtaining a “new” station 
catalog.

1 On the Data menu, click Imports.

2 Click on the WIMS Station Catalogs button as shown.

3 A dialog box will open. Select the weather station files you would like to 
add and click Open.
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4 When finished click Close and then click Close on the Import Fire and 
Weather Data dialog box.

5 An Import Complete dialog box indicates that the station catalog was 
added successfully.

To review, print or save the error log, click View Log.

To create a station catalog

1 On the Data menu, click Stations. The following dialog box will open:
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2 Click on the New button.

3 The Station Information dialog box shown below will open:

4 Populate the fields with reasonable values. 

At a minimum, an input file requires an observation data and one or more 
variables. Optionally, the weather Station ID may be included as part of every 
record.
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To edit a station catalog

1 To review the station catalog, click Stations on the Data menu.

2 Click the Station ID of your choice, and then click Edit.

The following Weather Stations dialog box lists all of the station catalogs 
available in your working set database.

The following Station Information screen shows station catalog 
“101028.”
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To delete a station catalog

1 Open the Data menu and select Stations.

2 The following Weather Stations dialog box will open.

3 Select the station you would like to delete and click Delete.
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4 The delete confirmation dialog box shown below will open. Click Yes to 
confirm or No to cancel.

Importing fire weather data

To import historical fire weather data - optional

1 On the Data menu, click Import.

2 Click Old Fwx Fires, and then double-click the historical fire weather 
data file(s) of your choice.

To import historical fire weather data retrieved in the 1998 data format, 
click New FW9 Files. Naming conventions for fire weather files are 
generally WX123456.FWX, or wxobs72a!12345! from ! to !.fwx,   
wxobs98a!12345! from ! to !.fw9. 

There are two standard formats for extracting fire weather observations from 
the National Interagency Fire Management Integrated Database (NIFMID) - 
the older FWX and the new FW9 formats. There are also other sources of 
these data (see Appendix D).

To import generic weather data

This functionality allows flexibility in importing data from alternate sources. 
It displays all weather observation elements available in FireFamily Plus and 
allows you to define data in your alternate weather file by selecting columns, 
the field delimiter, and date/time formats. 

1 Click on the Generic Wx Import button and you will be prompted to 
select a weather file for importing. The file should be tab, comma, or 
semi-colon delimited.D R
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As an example, the following figure sets up a comma delimited import format 
from a file containing Station ID, date (Obs Date), time, (Obs Time) 
observation type (Obs Type), temperature (Temp), relative humidity (RH), 
wind speed (Wind Speed), and precipitation (Precip Amt). Select fields in the 
order in which they appear in the file.
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2 If the file is for a single station and there is no station field in the import 
file, click the StationID box, select the Station ID from the list of 
available stations in the current working set, or check the box labeled 
Include All Stations in List to select from a list of all stations. Also 
select whether or not to overwrite or reject duplicate values. Duplicate 
values occur when the StationID, Observation Type, Date and Time 
match an existing record in the observations data table.

To access WRCC RAWS data

This functionality allows flexibility in importing hourly RAWS data from the 
Western Region Climate Center’s data lister (www.raws.dri.edu). 

Once at this website there are several ways to navigate to a region and 
station of interest.
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To download from the WRCC, follow these steps:

1 Go to the Western Region Climate Center website - www.raws.dri.edu. 

2 Select the state of interest from the map shown. For Alaska, Pacific 
Islands, Hawaii, and Caribbean Islands, click on the respective name on 
the map provided.

3 From this map, either click on the station of interest, or select the name of 
the station from the list of stations in the left panel.
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Note: The stations are not in alphabetical order by name but rather by 
WRCC station ID, so the station you are looking for may be further down 
the page in the left column. 

After you have located a station of interest, use the Data Lister function from 
the extensive menu located at the left of the screen:D R
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4 Define the data period of interest by defining the starting and ending dates 
in the following form. Once you have defined the data period, chosen the 
output format and entered the password (for data older than 30 days), 
click Submit Info to retrieve the data. Access to data older than 30 days 
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requires a password which can be obtained from the Western Region 
Climate Center by E-mailing: wrcc@dri.edu. 

5 Under Options, in the Data Format drop-down menu, select Delimited 
format (dat-Win/PC) as shown.

6 Click on the Submit Info button when the form is completed.D R
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7 Once your selection is returned, a dialog box as shown below will appear, 
allowing you to save the data to a location of your choice. 

8 View/and or save the data.dat file. 

You can open the file with a browser of your choice to view the data or click 
on the Save to Disk radio button to save the file. You may change the 
filename at this time or accept the default (data.dat)

Data.dat is the default name but you can change it to a more meaningful 
name.

9 If you specify a browser and click OK, an example similar to the 
following will open.
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An example data format is shown below:

To import WRCC data

The Data Lister from the WRCC does not include station numbers in either 
the WIMS or the internal WRCC classification scheme. Consequently, 
FireFamily Plus requires you to associate the retrieved file with a FireFamily 
Plus Station Catalog. D R

 A
 F T
4.15 June, 2009



FireFamily Plus User’s Guide Chapter 4. Importing data
1 After clicking on WRCC RAWS in the Import Fire and Weather Data 
Dialog Box, the following screen will appear. 

This screen shows only the stations that already have associated weather 
data.

2 Next check the Show all stations box at the lower right of the dialog box 
and you will be able to view a list of all NFDRS stations in the FireFamily 
Plus database. An example is shown below.

D R
 A

 F T
June, 2009 4.16



Chapter 4. Importing data FireFamily Plus User’s Guide
3 Select the station you want your data associated with and click OK. The 
following dialog box will open.

4 Select the weather file and click Open to select the weather file that you 
saved from WRCC and the data import process will begin.

5 Click on View Log and make sure that the Import Log has no errors.
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Warning: Imports from the WRCC may require considerable data quality 
control. The log lists the record number and date (yymmddhhmm) and the 
field in question.

An error message from a WRCC data import is shown below:

An example of hourly observations constructed from WRCC data is shown 
below. 

Note that SOW (State of Weather) is blank.

FireFamily Plus WRCC RAWS File Import Log 
Started: 02/01/2007 at 17:25:40 
 
************************************************** 
Import File Name: C:\Documents and Settings\lbradsha\My Documents\ffp4_data\mt_red_rock_wrcc_wx.tx
 WARNING: Record Number 1228, 8712060000 - Gust Speed (110) appears to be invalid 
 WARNING: Record Number 7792, 8809100100 - Gust Speed (281) appears to be invalid 
 WARNING: Record Number 17686, 8911130600 - Gust Speed (131) appears to be invalid 
 ERROR: Record Number 18954, 9001060800 - Temp (401) is invalid 
 ERROR: Record Number 18955, 9001060900 - Temp (401) is invalid 
 ERROR: Record Number 25749, 9010211700 - Temp (403) is invalid 
 ERROR: Record Number 25750, 9010211800 - Temp (303) is invalid 
 WARNING: Record Number 25879, 9010270400 - Gust Speed (136) appears to be invalid 
 ERROR: Record Number 27167, 9012210800 - Temp (-45.99) is invalid 
 ERROR: Record Number 27190, 9012220700 - Temp (-41.99) is invalid 
 ERROR: Record Number 27191, 9012220800 - Temp (-43.99) is invalid 
 WARNING: Record Number 35145, 9112010100 - Gust Speed (301) appears to be invalid 
 WARNING: Record Number 36018, 9201070700 - Current Precip (  3.3900) is invalid. Recip cou
reset. 
 WARNING: Record Number 37474, 9203101100 - Gust Speed (287) appears to be invalid 
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FWX and FW9 files from WRCC

WRCC also offers FWX and FW9 files for importing. You can use the 
standard FWX and FW9 data import options available in FireFamily Plus but 
the behavior of these data are slightly different because WRCC does not use 
WIMS station IDs. To import FWX or FW9 files, follow the Data Lister 
instructions but select the appropriate format from the Data Format pull-
down list as shown.

FWX and FW9 formats from WRCC do not have State of Weather (SOW) and 
FireFamily Plus will assume SOW = 0.
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The following example shows FWX and FW9 formatted files for Moose 
Creek, Idaho. 

Note that the WRCC station ID is “imoo” and that there is hourly data in 
the FW9 file.

Select the file with weather data as shown below:

Example FWX file  Example FW9 file 
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Upon importing the FWX and FW9 files into FireFamily Plus, the program 
will recognize the WRCC station ID, cross-reference the data to any existing 
data and copy the data over to a new station under the WRCC station ID.

The following is an example of an import error log showing WRCC ID 
“Imoo” cross-referenced to station 101028 (Moose Creek, Idaho).

A new station labeled with the WRCC station ID will appear in the SIG/
Station drop-down menu. The new weather data will not include State of the 
Weather (SOW) but will include Solar Radiation. It is assumed that SOW=0. 
Notice that you did not have to import a station catalog. The station 
information was populated automatically.
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Notice the format of Moose Creek (“imoo”). This weather data does not have 
a SOW entry but it does include solar radiation.

Importing federal fire occurrence data

Organizational structure

1 To import fire occurrence data, first select an agency. 
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The only default choices are USFS and DOI. Once an agency is selected, the 
appropriate button is highlighted for you to press. Use the RAW Files import 
for USFS and the WFMI Fire Import option for all DOI agencies. 
Additional agencies can be added to import any other fire occurrence data 
(see “Defining Custom Agencies and importing fire occurrence data” later in 
this Chapter).

The US Department of Interior (USDI), BIA, NPS, BLM, and Fish and 
Wildlife Service (FWS) now use National Wildfire Coordinating Group 
(NWCG) Unit Identifiers as shown in the following diagram. D R

 A
 F T
4.23 June, 2009



FireFamily Plus User’s Guide Chapter 4. Importing data
Forest Service fires are still recorded by Region/Forest/District.

To import Forest Service fire occurrence data (RAW files)

1 In the Agency box, type or select USFS.

2 Click RAW Files, and then double-click the fire occurrence file(s) of your 
choice.

3 When finished click OK, and then click Close.

Since FS fire occurrence data is verified for duplicate records, this import 
process may require several minutes. For datasets containing more than 
10,000 records, this process may require several hours! 

Department of Interior WFMI files

The BLM BIA, NPS, and now the FWS use the Wildland Fire Management 
Information (WFMI) System. These records use a new data format called 
“PCHA_FFP” (Personal Computer Historical Analysis). 
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The following is an example of PCHA_FFP formatted fire records. 

1 Select a file.   The following Select Fire Types to Import dialog box will 
open.

2 Click Open.

3 Select Fire Types to Import by checking the individual boxes at the left 
side of the following dialog box or click the Select All button to include 
all of the fire types listed.

4 When you are finished with your selections, click OK.
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Additional fire types (19, 25, 26, and 37) have been added with FireFamily 
Plus version 4.0.

Defining Custom Agencies and importing fire occurrence data

Creating the organizational structure

To import fire occurrence data from Non-Federal agencies, you must first 
define the organizational structure of the agency. 

1 Select the Data -> Agencies menu option. 
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The following structure is assumed to exist.

Selecting the Agencies menu option will bring up the following dialog box:

 Agency 

Region 1 Region N 

Unit 1 Unit N Unit 1 Unit N 

SubUnit 1 

SubUnit N 

SubUnit 1 

SubUnit N 

SubUnit 1 

SubUnit N 

SubUnit 1 

SubUnit N 
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2 To create a new agency, press the New button and the following dialog 
box will appear.

3 Enter a one to 12 character name for the agency. Spaces are allowed. A 
new agency will be created. 

4 Next, if applicable, you can create Regions. Click on the new agency 
name to highlight it and press the Regions button.
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The following dialog box will open.  Ensure that the Code field is populated 
wtih the code as it will appear in the import file.

5 Once a zone is identified, you can further describe the organizational 
structure using Units. Select a region from the list to highlight and press 
New.D R
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Pressing the Units button will bring up a dialog box similar to the Agencies 
and Regions boxes. 

6 Again press New and define the units within that particular region and 
ensure that the unit code matches the unit code as it is displayed in the 
input file. Subunits can be defined in the same way. Continue adding 
regions, units, and subunits until the structure of the new organization is 
defined.

The following shows an example of a custom-defined agency (Montana), 
Region(s), and Unit(s).

Importing generic or user-defined fire occurrence data

The custom agency fire occurrence import functionality has been replaced 
with a generic fire import function in FireFamily Plus 4.0.
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1 Click on Data -> Import and the following Import Fire and Weather 
Data dialog box will open.

2 Select Generic Fire Import and the following box will appear:

3 Select a generic fire import file.

The Generic Fire Data dialog box and functionality has been extensively 
reworked in FireFamily Plus 4.0. The first time you see the following dialog 
box for a custom agency, you will need to define the format of the input file.
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To properly import a file, you should:

1 Select the fields in the order that they appear in the file. Ensure that all 
required fields (identified with an *) are selected.

2 Define a delimiter (tab, comma, or semi-colon).

3 Select a date and time format.

4 Select the fields in the order they occur in your data file along with some 
specifics on the delimiter and date/time formats.

Move the fields from Available Fields to Selected Fields by highlighting a 
field in the Available Fields column and pressing the > > > > button. Or you 
can double-click the field. Required and commonly used fields are at the top 
of the available field list. 

You can insert default values for Region/Unit/Subunits and control 
duplicate checking as in FireFamily Plus Version 3.0.

D R
 A

 F T
June, 2009 4.32



Chapter 4. Importing data FireFamily Plus User’s Guide
After selecting all of the fields you want to include (note that many more 
fields are available than in Version 3.0.5, including location, latitude, and 
longitude), the fire data are imported by selecting the Import Fire Data 
button. The example below includes the FireFamily Plus required fields plus 
county, fire name, and location by latitude/longitude.

 

User variables

FireFamily Plus provides the ability to import user-defined variables that are 
associated with a pre-defined weather station. Defining user variables is a 
two-step process. First you must specify the layout of a text file that will 
contain the user-defined variables. Secondly you must import the data into the 
current working dataset. An associated station must exist for the data to be 
successfully imported. However, you can create a “dummy” station if none 
exists by selecting Data, Station, and New as shown and by populating fields 
with reasonable values.
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At a minimum, an input file requires an observation date and one or more 
variables. Optionally, the weather station ID may be included as part of every 
record. Once the data are imported, the new user defined variables are 
available in all FireFamily Plus modules with the exception of Percentile 
Weather.

Managing user variables

1 Select Data and User Variables to add new variables of your choice by 
importing a text file. 

2 First choose Manage (you should see the following screen):
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3 Click on New and select variables as shown below:

4 Add the full name of the variable you wish to enter (maximum of 30 
characters) in the first box and then select an abbreviation (maximum of 
20 characters). Choose an appropriate value for Decimal Places.

5 Analysis Bin Size is used to collect numbers in the cumulative list. Only 
values of 0.1, 1.0, and 10 should be used. If the daily value of the variable 
you have selected ranges from 0 to 10 and if the variable has decimal 
places (for example, precipitation), use an analysis bin size of 0.1. If your 
daily variable ranges from 0 to 500 and has no decimal places, then select 
a bin size of 1.0. If your expected range may be greater than 500 for a 
daily value (i.e. Keetch-Byrum Drought Index) use a bin size of 10.

6 Click OK.
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Importing user variables

1 Next click Import Data. If the station does not exist, a new station will be 
added to the station catalog. 

You will see a screen similar to the following example: 

2 Select an appropriate Date Format and Field Delimiters and choose the 
variable or variables you have created from the Available Fields column.

User variables should generally be associated with an existing weather 
station.
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3 Click Import. You should see the following screen:

Viewing observations

1 Next choose Data -> User Variables -> View Observations. D R
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You should see a screen similar to the following diagram. Each row defines a 
column of data in the input file.

Your new variable is available for use in various FFP Weather applications 
including Climatology, Event Locator, Pocket Card, and many of the 
Season Reports. A few examples are shown below:D R
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User-defined variables are also available for use in Fires Analysis as shown in 
the following Fire Analysis Options dialog box:D R

 A
 F T
4.39 June, 2009



FireFamily Plus User’s Guide Chapter 4. Importing data
D R
 A

 F T
June, 2009 4.40



Chapter 5.  Working with FireFamily Plus

This chapter explains how to perform some common operations within 
FireFamily Plus. Topics include:

• Defining an active working set.
• Working with Station Metadata.
• Working with Special Interest Groups (SIGs).

Defining an active working set
This section explains how to define an active working set and how to set fire 
associations. FireFamily Plus allows you to create and populate new 
databases. Multiple databases can be open, but only one database is “active” 
at any one time.

Think of the “working set” as a filter of the active database. You may not be 
interested in all of the weather or fire data in a database. By filtering the 
database, you can use the data that pertains only to your specific fire danger 
analysis needs. For example, you may choose to analyze the potential for the 
fall fire season or be interested in determining the window for the spring 
prescribed fire season. For these examples and in most analyzes in FireFamily 
Plus, you need to carefully consider how to define the Active Working Set.

Setting fire associations allows you to define which fires are associated with 
the weather station or stations in the working set. You can also blend fires 
from different agencies.

All FireFamily Plus output directly relates to the configuration of the working 
set. Therefore, be sure that each of the required elements in the working set 
accurately reflects your data requirements. 

Problems with output are usually caused by an incorrect working set.

To define the Active Working Set

1 On the SIG/Station box, select the Station ID or Special Interest Group 
(SIG) of your choice. 

In the following example, Station 240107, located at the Libby Ranger Station 
on the Kootenai National Forest is selected, as seen in the SIG/Station menu 
window.D R
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2 Change the remaining Active Working Set Definition fields as needed. 
Using the scroll buttons on the Data Years selection allows you to select 
the years of interest available with a particular station. The Annual Filter 
allows you to select the time of year (month and days) to include in the 
analysis. The Analysis Period Length controls the number of days used 
to define the data grouping. Finally, the Fire Associations button allows 
you to select the fires that will be associated with the weather station’s 
data.

Note: Fires Analysis is a term we use when comparing indices to fire 
occurrence.

In the example shown above, the following inputs have been selected:

• Station or Special Interest Group (SIG) 240107 - LIBBY RANGER 
STATION.

• Data years 1954 through 2006.

• Annual Filter (time of year to analyze) May 1 through September 30.

• Analysis Period Length (number of days averaged into analysis) 1.

• SIG/Station Metadata (edit site data or change fuel model). The example 
shows defaults.

The analysis period lengths are bins, not moving averages.
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About the Enable Auxilliary Year Overlays checkbox

The Enable Auxiliary Year Overlay box allows you to overlay years of data 
outside of the Data Years you selected. Checking the Enable Auxiliary Year 
Overlay box will allow you to add specific fire season information to your 
graphs (see Chapter 6 “Working with reports and graphs” for more 
information). 

You must select the Enable Auxiliary Year Overlays check box on the 
Active Working Set before you can create an overlay from a data year 
outside the working set. Statistics (average, max., min., etc.) will only be 
computed from years within the “Data Years.”

To set fire associations

1 Click Fire Associations.

2 On the Set Fire Associations dialog box, click the tab of your choice.

3 Select the Region(s), Unit(s), and Sub Unit(s) of your choice.

In the example, the following selections were made:

• USFS

• Northern Region (R1)

• Kootenai NF

It is important to remember that only highlighted choices are included in 
the fire association selection.  Items that are not highlighted will not be 
included.
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Fire Unit and Subunit identifiers have been changed. The BIA, NPS, and 
BLM now use NWCG Unit Identifiers.

4 To verify that only the desired fire associations are selected, click View 
Selections, then click OK.

5 If you want to review fire data, click on View Fires. A table with the fire 
data (date, size class, cause, etc.) will open. An example is shown below.

Working with Station Metadata in the Station Catalog
There are three changes to the station catalog in Version 4.0 of FireFamily 
Plus. 

• The latitude and longitude are now GIS friendly.

• Brush Dormant Date: To support areas where freezes do not generally 
occur, the capacity to allow shrubs to go into dormancy is supported by a 
new Use Brush Dormant Date box. This was requested by Russ Gripp 
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and allows FFP to better emulate user control in WIMS. The default value 
for this field is unchecked. If the following conditions are met (‘78 model 
only), the brush dormant date will apply:

•         the brush dormant date is selected.

•         a valid date is entered.

•         the vegetation has cured.

•         the observation date is greater than the dormant date.

•         the live vegetation state is put into a dormant state so that woody fuel 

               moistures do not increase with fall rains.

If selected, a Use-Weighed 10-HR Sticks check box enables FFP to ignore 
weighed sticks and compute the 1- and 10-hour moisture by algorithm for the 
period of record. This allows for a consistent climatology for stations that may 
have some years of weighed sticks and some years without.

To export metadata for all stations

Station metadata can be exported to a text file. 

1 Click on the Data drop-down menu and select Stations.

2 Select a station of interest and click Export list.

The following Export Station Metadata dialog box will open. 
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3 Select the fields and formats you would like to export.

4 Click Export Text file.

The following shows an example of station metadata export.

Since the file shown above is comma delimited, you can bring it into an Excel 
spreadsheet as shown:

FireFamily Plus Station Metadata Export 
   printed on: 04/19/2007   at  03:04:25 PM  (from run # 34) 
   using database: C:\Documents and Settings\lbradsha\My Documents\ffp4_data\ffp4_default
 
Station ID,Name,Latitude,Longitude,Elevation,Station Type,Site 
#,State,County,Agency,Region,Unit,NFDRS fuel model,Use 88?,Climate class,Slope 
class,Aspect,Position on slope,Herb annual?,Greenup date,Freeze date,Herb moisture,Shrub 
moisture,Initial KBDI,Deciduous?,Avg. precip,Initial 1000h,FM 1=10 ? 
015902,OPNPND,  31.09444, -86.54861,275,4,1,AL,Covington,USFS,09 Eastern Region 
(R9),CONECUH,C,Y,3,1,4,,N,,,,,624,Y, 62.00, 25.00,Y 
040611,REDDING,  40.51579,-122.29220,500,4,1,CA,Shasta,,,NWS,B,N,2,1,0, ,Y,04/24,11/01,,,
33.00, 15.00,N 
245410,RED ROCKS,  44.69917,-111.82330,6690,4,1,MT,Beaverhead,USFS,01 Northern Region D R
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Working with Special Interest Groups (SIGS)
A Special Interest Group (SIG) is a collection of weather station catalogs that 
can be grouped together to analyze fire danger climatology. You can group as 
many stations as you wish, then weigh the importance of each station within 
the SIG. In this way, you can adjust the influence of each station when 
performing FireFamily Plus calculations.

FireFamily Plus creates new pseudo (“averaged”) weather records for each 
day using all available data from every station in the SIG. If any station within 
the SIG has a data record for a particular day, the SIG will have a weather 
record for that day. If no stations have a data record for a particular day, the 
SIG will not have a weather record for that day.

To create a SIG

1 On the Data menu, click SIGS, and then click New.

2 In the SIG Name box, type a meaningful name for the SIG.

Although you can delete and recreate a SIG, once you save it you cannot 
change its name.

3 In the Description box, type a description that identifies the SIG and its 
purpose.
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4 Under Available Stations, select the station of your choice, then click 
>>>> to include that station in the SIG.

5 When finished adding stations to the SIG, click OK.

The following diagram shows the Special Interest Groups dialog box.

The following diagram shows the Special Interest Group Attributes dialog 
box. From here, you can include or remove station catalogs in the SIG that 
have been imported into your database. 

Only station catalogs with weather data will display in this dialog box. To 
import additional catalogs or weather data, see “To import a station catalog” in 
Chapter 4.
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The following diagram shows the new SIG as it appears in the Special 
Interest Groups dialog box. 

To set weights of stations in a SIG

Weight factors are relative in FireFamily Plus. Initially, every station in the 
SIG is assigned a weight factor of “1.0,” denoting equal weight for all 
stations. To increase a station’s weight for your analysis, simply increase its 
weight. Weights are ratios. 

In the following example, station 40611 has twice the weighting as the 
other stations when computing the single value from the three stations. 
For example on a given day, if the Burning Indices (BI’s) were 10, 20, and 
30 at stations 040510, 040611, and 040628 respectively, the weighted BI 
would be: (1*10 + 2*20 + 1*30/3 = 26.7). If the stations were equally 
weighted, the value would be (10 + 20 + 30) /3 = 20.

1 To set weights, from the Special Interest Groups dialog box, select the 
SIG Name of your choice, and then click Set Weights.D R
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The following diagram shows the Set Station Weights dialog box.

2 For each station, type the appropriate weight, and then click OK when 
finished.D R
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To save a SIG

1 When finished adding stations and setting weights to each station to the 
SIG, click OK.

2 To exit the Special Interest Group dialog box, click Close.

To edit a SIG

1 On the Data drop-down menu, click SIGS.

2 From the Special Interest Groups dialog box, select the SIG Name of 
your choice, and then click Edit.

3 Add and remove the station(s) of your choice, then click OK when 
finished.

D R
 A

 F T
5.11 June, 2009



FireFamily Plus User’s Guide Chapter 5. Working with FireFamily Plus
4 Click Set Weights, type the appropriate weights for each station included 
in your SIG, and then click OK.

5 To exit the Special Interest Group dialog box, click Close.

To delete a SIG from the database

1 On the Data menu, click SIGS.D R
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2 From the Special Interest Groups dialog box, select the SIG Name of 
your choice, and then click Delete.

3 Click Yes to confirm or No to cancel.

The following diagram shows the delete confirmation dialog box.

4 To exit the Special Interest Group dialog box, click Close.

To export metadata for stations in a SIG

SIG metadata can be exported in the same way that station data can be 
exported. Select Data > SIGS from the top menu bar.  Choose a SIG and click  
Export list to open the Special Interest Groups dialog box.D R
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The Export Station Metadata box opens, allowing you to select the fields 
you would like to include in the SIGS export. 

1 Select the fields to include.

2 Click the Export text file box.

Refer to page 5.6 for an example of station metadata export.  When you 
export station metadata for your SIG, one record will be exported for each 
station . As discussed in the section “To export metadata for all stations,” a 
comma-delimited file can be brought into an Excel spreadsheet (page 5.7).
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Chapter 6.  Working with reports and graphs

This chapter explains how to work with reports and graphs in FireFamily 
Plus. Topics include:

• Reviewing weather data and generating reports and graphs
• Working with overlays
• Merging graphs
• Changing the look of your statistical graphs
• Display options
• Working with season reports
• Working with weather data
• Reviewing fire occurrence data
• Using the event locator
• Using the NFDRS calculator

Reviewing weather data and generating reports
This section explains how to review weather data and generate Climatology 
statistical tables and graphs. 

To review weather observations

1 On the Weather drop-down list, point to View Observations, and then 
click All.
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The following Weather Data screen lists the weather observations for station 
“245410.” 

To sort by any field, right-click on the column heading of your choice. To 
adjust column width, drag the column heading to the desired width.

To review weather data by generating a statistical table

1 On the Weather drop-down list, click Climatology. 
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2 Select the Stats Table check boxes of your choice. In the following 
example, output for “Burning Index” is shown.

D R
 A

 F T
6.3 June, 2009



FireFamily Plus User’s Guide Chapter 6. Working with reports and graphs
3 Click Run.

The CP #1 and CP #2 columns identify the critical percentiles that are used to 
generate statistical tables, graphs, daily frequencies, and pocket cards. 

The following example shows the Statistical Table for Burning Index at the 
Libby Ranger Station. As shown in the previous diagram, the 90th critical 
percentile (CP #1) was used to generate this table.D R
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Column headings (from left to right) are described as follows:

• No.Years: The number of years for each period.

• Mean: The arithmetic mean for the period.

• Std. Dave.: The standard deviation about the mean for the period.

• Critical Pcntile: The value of the 1st critical percentile (CP #1) in the 
Climatology Options screen.

• Highest Avg, Year: The highest mean for the period and the year of 
occurrence.

• Lowest Avg, Year: The lowest mean for the period and the year of 
occurrence.

• High, Year: The highest daily value in the period and the year it 
occurred.

• Avg. High: The average of the maximum daily values in each period/year.

• Std. Dev.: The standard deviation of the maximum daily values in each 
period/year.

• Median High: The median of the maximum daily values in each period/
year.

• Low, Year: The lowest daily value in the period and the year it occurred.

• Avg. Low: The average of the minimum daily values in each period/year.
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• Std. Dev.: The standard deviation of the minimum daily values in each 
period/year.

• Median Low: The median of the minimum daily values in each period/
year.

Only the data defined by the active working set is included in the statistics 
table.

To review weather data by generating a statistical graph

1 On the Weather drop-down menu, click Climatology. 

2 Select the Stats Graph check boxes of your choice (use “Burning Index” 
for this example).

In this example, clear any check boxes such as “Burning Index” in the 
Stats Graph column.

3 Click Run.

The following Burning Index Statistical Graph is produced and both CP #1 
and CP #2 are displayed.

Column Name On Line Graph? On Bar Graph?

No. Years No No

Mean Yes Yes

St. Dev No Yes

Critical Pcntile Yes Yes-Pitle Tics

Highest Avg/Yr Yes Yes-Range Tics

Lowest Avg/yr Yes Yes-Range Tics

High, Year No No

Avg. High No No

Sd. Dev. no No

Median High No No

Low, Year No No

Avg. Low No No

Std. Dev. No No

Median Low No No
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To smooth out the curve by grouping days in larger bins:

1 Close the open windows until you get back to the Working Set database 
window.

2 In the Working Set window change the Analysis Period Length (Days) 
from 1 to 3.
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3 On the menu bar, click Weather -> Climatology.

4 Click Run to create the Burning Index graph again.

Notice the difference in the graph’s appearance and how the numbers for 
Burning Index no longer reach the levels seen in the one day analysis. 

To resize a statistical graph

1 To maximize the statistical graph of your choice, double-click anywhere 
on that graph.

2 Slide the graph to the left or right for the view you prefer.

The following diagram shows how to adjust the size of the statistical graphs. 
You can click and hold the bar that separates the two statistical graphs, then 
slide the bar to the right or left to obtain the desired size.D R
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To determine a specific value on a statistical graph

If you click anywhere on either of the graphs, the values of that point appear 
in the lower right corner of the window in the X Value and Y Value boxes. 

1 Click the point of your choice.

2 The values are displayed in the boxes at the lower right corner.

The following diagram shows the X value and Y values of a particular point 
on a statistical graph.
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Working with overlays
After you create a statistical graph, you can add an overlay to highlight up to 
three specific years of interest.

Using the Enable Auxiliary Year Overlays check box

The Enable Auxiliary Year Overlays check box allows you to overlay years 
of data outside the Data Years specified for the Working Set. The following 
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diagram shows the location of the Enable Auxiliary Year Overlays check 
box. 

You must select the Enable Auxiliary Year Overlays check box on the active 
Working Set screen before you can create an overlay from a data year that is 
outside the working set.

To create an overlay on a statistical graph of your choice

1 Be sure that the Enable Auxiliary Year Overlay box is checked in the 
Working Set window.

2 On the Options drop-down menu, click Overlays.

3 Click New, then select the Year, Color, Width, and Line Style to chose a 
value for the overlay. (The following example shows the 2001 and 2003 
seasons as overlays).
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A value of “3” in the Width column can make the lines easier to see. 

You can adjust the Color, Width, and Line Style to enhance the appearance 
of your statistical graphs.

4 Double-click in the Color box to bring up the color picker. 

5 To review the appearance of the overlay, click Apply.

6 To delete an overlay year, click on that year and click Delete.

7 When finished adding new overlays, click OK.

If applying the options specified above, your Statistics Graph should 
resemble the following example.

You can select up to three possible overlays.
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A Fire-Day symbol may be attached to each overlay year. The legend for 
these symbols is found in the upper left corner of the graph. Fire-Day 
symbols are only available on overlay years. Fire-Day symbols can be 
controlled in Options -> Graph Options -> Fires.

The three (shown as circled above) numbers following the “Year Overlay” 
legend at the lower left, represent the number of Fire-Days, Large Fire-
Days, and Multiple Fire-Days.

The following diagram shows the Burning Index statistics graph and weather 
percentile graph for the Redfeather Station. Note the added overlays for the 
1977 and 1978.
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Merging graphs
The Merge selection on the Options drop-down menu allows you to merge 
up to three variables onto your base graph.

To merge additional variables onto your base graph

1 On the Weather drop-down menu, click Climatology. 

2 Select the Stats Graph check boxes of your choice, and then click Run.

Legend for symbols
on the overlay

Each overlay legend shows the year and fire-days (number of fire-days/number of large fire-days/
multiple fire-days). In 1977, there were 26 Fire Days/ 2 Large Fire Days/ 0 Multiple Fire Days.multiple 
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3 On the Options drop-down menu, click Merge.

4 In the Merge Graphs dialog box, select the years of Data to Graph, and 
then select the Variable, Color, Width, and Line Style for each variable 
of your choice.

The following diagram shows the Merge Graphs dialog box.

.

5 When finished, click OK.

The following diagram shows a resulting Merge Graph for “FM1000” (1000-
hour fuel moisture), “SC” (spread component), “RH” (relative humidity), and 
“ERC” (energy release component).
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Note that each variable has its own Y-axis scale.

Changing the look of your statistical graphs
Graph Options on the Options drop-down menu opens a dialog box that 
allows you to modify the appearance of your statistical graphs.

The Graph Display Options windows has the following six tabs - General, 
Bar Graph, Line At Average, Fires, Fire Danger Projections, and Batch 
Auto Save. When you are viewing the Graph Options window with one or 
more active graph windows open, you can apply your options to the viewed 
graph (Apply) or to all active graph windows (Apply to All).

If Graph Options is accessed without an open graph window, the Apply and 
Apply to All selections are dimmed and you can only set the configuration by 
using Set as Default. You can use the Set as Default selection button at any 
time. 
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The General tab allows you to configure the appearance of graph grid lines, 
whether your default graph type is the Statistical Bars or Line at Average. 
You can select none, one, or two overall critical percentile values on the graph 
“CP 1” and “CP 2” (see page 6.3). The overall percentiles are those for the 
entire working set (data years and annual filters) and appear as horizontal 
lines across the graph that do not change with seasonal dates.

The CP 1 and CP 2 check boxes allow you to graph the critical percentile 
values that are defined on the Climatology Options dialog box. For more 
information, see “To review weather by generating a statistical graph,” earlier 
in this chapter.

The Bar Graph tab allows you to specify if you want to display maximum 
and minimum values (Range Tics) and/or critical percentile values (Critical 
Percentile Tics) for each bin of your analysis period. The following diagram 
shows the settings available on the Bar Graph tab.
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The Line At Average tab allows you to select and configure up to five graph 
lines. You can use this tab to change the color and width of the Average, 
Minimum (Min), Maximum (Max), CP 1, and CP 2 lines. You can also clear 
the Minimum, Maximum, CP 1, and CP 2 check boxes to eliminate those lines 
from your statistical graphs. CP values are for each “bin” of the analysis 
period. Values will change with the seasonal dates. The following diagram 
shows the settings available on the Line At Average tab.

Hint: You cannot remove the “average” line from the graph, but you can 
select the color “white” to hide it. 

The Fires tab allows you to define which type of Fire Days, Large Fire Days, 
and Multiple Fire Days will be displayed on overlay years on either the line or 
Bar Graph. You can select which Fire Cause to display and can specify the 
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number of acres for Large Fires and the number of Fires for a Multiple Fire 
Day (for overlay years only). The following diagram shows the settings 
available on the Fires tab. In this example (the default), all fire days for all 
causes are shown with large- and multiple- fire day thresholds of ten acres and 
five or more fires.

The Fire Danger Projections tab allows you to modify the line color, width, 
and style of your fire danger projection. The following diagram shows the 
settings available on the Fire Danger Projections tab. (For more information 
about the changing the graph options on this tab, see Chapter 9, “Working 
with fire danger projections”).

The Batch Auto Save tab allows you to save images at a specified resolution 
and specified file type (BMP, GIF, JPEG, or PNG) to a directory of your 
choice. The following diagram shows the settings available on the 
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BatchAutoSave Tab where you can define the resolution, type, and location 
of graphic images created by Batch runs. Click the Browse for folder button 
to navigate to a directory/folder. A “.” in the window indicates the working 
directory of the current active database. (For more information on 
BatchAutoSave, see Chapter 11, “Batch functions”).

Hint: Your directory must already exist; you cannot create a directory from 
here.

Introduction to annotations

Annotated versions of a Line at Average Graph, Statistical Bar Graph, and 
Percentile Graph are shown as follows.

The following diagram shows annotations for an example Line at Average 
Graph.
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The following diagram shows annotations for the statistical bar graph.

D R
 A

 F T
6.21 June, 2009



FireFamily Plus User’s Guide Chapter 6. Working with reports and graphs
The following diagram shows annotations for the Percentile Graph.
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Report options
You can now control how information is displayed in reports by using the 
Options drop-down menu and selecting Report Options.
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To configure information included in a report

1 Click on Options -> Report Options. The following Report Detail 
Options dialog box will open.

2 You can control the information included in the “Report Headers” by 
selecting any of the four levels of information on the Report Headers to 
Include... tab as shown above.

3 If you intend to save a report and then import into another program, you 
can set the delimiter of your choice by using the Report Detail Options 
dialog box and by clicking on the Delimiter tab as shown below.D R
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Note: The Delimiter controls the look of the daily list, (and hourly lists) so 
that the reports are easier to save and import into other programs such as 
spreadsheets or statistical analysis. Set the delimiter to “comma” to save 
and directly import into Excel programs.

To view additional header information while working with active graphs, 
click Options -> View Header Info as shown.

The View Header Information option will show the information selected on 
the Report Detail Options dialog box.

Working with Season Reports
Season Reports summarize the seasonal variations of fuel moistures, NFDRS 
indices, and components. You can generate the following:

• Persistence Probability - reports the chance that tomorrow’s variable 
will be the same as today’s. The higher the persistence, the less likely the 
weather will change.

• Severity List - ranks each year at a fire weather station in terms of a 
selected variable exceeding a user-defined percentile level.

• Severity Summary - summarizes the Severity List.

• Probability Analysis, - shows how often you can expect values of your 
adjective class to occur, and provides detailed information needed to 
perform fire management activities.
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• Daily Listing - lists weather records as daily values and optionally fire-
day occurrence.

• Percentile Weather - identifies the frequency of occurrence of a 
particular variable of your choice.

• FlamMap Fire Risk Export - allows you to select wind records and 
parameter options to export to FlamMap.

,.

To generate a Persistence Probability report

1 On the Weather drop-down menu, click Season Reports, and then click 
Persistence Probability. The Persistence Probability dialog box will 
open.

2 Using the Index drop-down list, select the variable of your choice.

3 Type in the Display Ranges values (Min, Max) for each class, and then 
click OK.

D R
 A

 F T
June, 2009 6.26



Chapter 6. Working with reports and graphs FireFamily Plus User’s Guide
The following diagram shows the Persistence Probabilities dialog box 
for “Precipitation Amount”.

The resulting “Precipitation Amount - Persistence Probabilities” report 
shows the probability and amount of precipitation to expect during the given 
period.
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To generate a Severity List

1 On the Weather drop-down menu, click Season Reports, and then click 
Severity List.

2 In the Index box use the drop-down menu to select the variable of your 
choice.

3 Type the Critical Percentile value, select the appropriate Display 
Values, and then click OK.

The following diagram shows the Seasonal Severity List dialog box for 

Wind Speed greater than the (critical) 97th percentile

.

The resulting Wind Speed - Severity List report shows the number of 

years that had high winds during the period from May 1st through 

December 31st.
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To generate a Severity Summary

1 On the Weather drop-down menu, click Season Reports, and then click 
Severity Summary.

2 In the Index box use the drop-down menu to select the variable of your 
choice.

3 Type the Critical Percentile value, select the appropriate Display 
Values, and then click OK.D R
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The following Generate Seasonal Severity Summary dialog box shows 
the 1000-Hour Fuel Moisture for days below the critical percentile of “3,” 
(the driest days).

The resulting 1000-Hour Fuel Moisture - Severity Summary report 
measures the number of days with large fuels below the critical percentile of 
“3.”
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To generate a Probability Analysis

1 On the Weather drop-down menu, click Season Reports, and then click 
Probability Analysis.

2 From the Index 1 drop-down list, select the variable of your choice. 

3 From the Index 2 drop-down list, select another variable of your choice. 

4 Type in the Index 1 Display Ranges, type in the Index 2 Display 
Ranges, and then click OK.

The following diagram shows the Probability Analysis Report dialog box 
that determines the likelihood of a value of Energy Release Component given 
the value of Spread Component.

The resulting Probability Analysis report shows the probability of a high 
Spread Component value given a high Energy Release Component.D R
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To generate a Daily Listing

1 On the Weather drop-down menu, click Season Reports, and then click 
Daily Listing.

2 Select the Date Format, Time Format, Fire Outputs, Fire Cause Filter 
and General heading information of your choice.

3 In the Available Variables list, highlight the variables of your choice, and 
then click >>>> or Select All.

4 When finished adding variables to the Selected Variables list, click OK.

5 The following diagram shows the selected variables for the Daily Listing.
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The resulting “Daily Listing” shows the recorded/calculated values for 
working set observations for Energy Release Component, and number of 
Fires, and Large Fires.

Hint: Selecting “comma-delimited” allows you to save the file as a *.csv 
file which opens directly in Microsoft Excel.D R
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You can also save the Daily Listing as a .txt or.cvs file and import it into 
spreadsheet and/or graphics software applications.

To generate a Percentile Weather

1 On the Weather drop-down menu, click Season Reports, and then click 
Percentile Weather.

2 From the drop-down list in the Percentile Weather Analysis Variable 
dialog box, select the variable of your choice. 

3 Click OK and the following dialog box will open.
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4 Select the wind direction and/or other class definition variables of your 
choice and click on Calculate (1). 
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5 Averages and Calculated values are completed. Click Calculate (2).

6 Calculated SC and ERC values are determined.
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7 Click Done (3) and the following Percentile Weather for RERAP dialog 
box is generated for the variables and wind directions you selected.

FlamMap Fire Risk Export

FlamMap Fire Risk Export allows you to select wind records and specify 
parameter choices to export to FlamMap.

1 Select Weather -> Season Reports -> FlamMap Fire Risk Export and 
the following Fire Risk Export Winds Parameters dialog box will 
open.
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2 Type in a Calm Wind Upper Limit or use the spinner box to select a 
value.

3 Specify the Wind Record Data Years you would like to include.

4 Select the Wind Record Time of Year you are interested in (Start 
Month/Day and End Month/Day). 

5 Select the Wind Record Time of Day (Start Time and End Time).

6 Choose the Wind Record Type (Ten Minute Average, Gusts, or Both) 
by checking a radio button.

7 Check the Include Monthly Wind Summaries and/or Generate 
Windrose boxes if desired.

8 Click OK to export the data to FlamMap.

 

FlamMap does not have to be open.

9 Save the file if desired (File -> Save).
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Working with weather data

Variables

A number of new Climatology Option variables are included with FireFamily 
Plus version 4.0. These new variables include: Gust Direction, Gust Speed, 
Solar Radiation, Wet Flag, Dew Point Temperature, Vapor Pressure Deficit 
(Max and Avg), and Live Fuel Index (described below). Vapor Pressure 
Deficit and Live Fuel Index are used to calculate aspects of plant activity.

Live Fuel Index (LFI)

The Live Fuel Index is a bioclimatic index of plant activity and relates to the 
state of live vegetation. It is a relative index of plant functioning and can show 
events like greenup and sensecence of foliage as well as curing of herbaceous 
fuels. 

LFI is calculated as the product of three indicators relating to the main drivers 
of plant activity: temperature, moisture, and light. The temperature indicator 
uses minimum temperature, the moisture indicator uses vapor pressure deficit 
(VPD) and the light indicator uses daylength. For each variable, limits are 
defined where plants are either unconstrained or fully constrained by a 
particular meteorological variable. These limits can be set using the Options 
> LFI Options menu selection. 

You can select either maximum vapor pressure deficit or average vapor 
pressure deficit for the calculations. You can also set the LFI running average 
period for the index (expressed in days). The LFI Options dialog box is 
shown as follows:D R
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The default live fuel index values shown in the dialog box have been 
evaluated over a large range of ecosystems and are sufficiently general to use 
without modification but you have the option to control the limits.

Units for the values presented are in degrees Celsius for temperature 
limits, Pascals for the vapor pressure deficit (VPD) limits, and seconds for 
the day length limits.

Custom Yearly Initialization

To account for variable greenup dates, and to better support the Canadian 
System, the Custom Yearly Initialization (Custom Yearly Inits) function has 
been added to FireFamily Plus.

1 Click on the Weather drop-down menu.

2 Select Custom Yearly Inits.
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3 The following Custom Yearly Station Inits dialog box will open. Use 
this initial screen to manage the Custom Yearly Station Initialization 
(Custom Yearly Station Inits).

4 Click on Create New and the following screen will appear.D R
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5 Select a range of years to use. The initial start up values, derived from the 
Station Catalog are already present. 

6 Click on Create custom init and then check the Enable the custom 
yearly inits... box. 

7 To edit, click Edit/View. Use the following dialog box to edit greenup 
dates as you wish.

.

8 Save changes as needed.

9 To delete a year, highlight and click Delete.

Years are deleted one record at a time.
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The following example shows different greenup dates in 2000, 2001, and 
2005.
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Winds

FireFamily Plus 4.0 includes more advanced sub-daily wind speed/directory 
display and analysis tools for datasets with hourly data. These tools remain as 
Weather -> Winds menu options.

.

1 Select Winds from the Weather menu and the following dialog box will 
open:

You can define six periods of interest for the wind analysis. These analysis 
periods are divided into the increments shown and can either be combined or 
split into groups. 

2 After selecting the desired analysis period(s) and clicking OK, both 
tabular and graphical wind analyses will be displayed as follows.
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This table is an example of the frequency listing of the Winds analysis. It 
shows the frequency of wind speeds binned into categories by both speed and 
direction.

Wind roses are also displayed using the Weather -> Winds option. The 
length of each bar shows the percentage of data falling into each category and 
the length of each colored bar within a particular wind direction shows the 
relative proportion of each wind speed within that category.  The bar color/
thickness relates to Wind Speed Category and the bar segment lengths relates 
to the frequency.  D R

 A
 F T
6.45 June, 2009



FireFamily Plus User’s Guide Chapter 6. Working with reports and graphs
Wind roses generated from hourly data will be separated into 16 wind 
directions whereas those generated from daily data will use eight wind 
directions (N, NE, E, SE, S, SW, W, NW, and calm).

To generate a wind report by month

1 Change the Analysis Period Length (Days) to 28.

2 On the Weather menu, click Winds. 

The following Wind Speed vs. Wind Direction report shows the 
prevailing wind speed range and direction for the month of May. Use the 
scroll bar to review other months.D R
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Reviewing fire occurrence data
This section explains how to generate a summary graph of fire occurrence 
data. You can generate a summary graph of imported fire occurrence data that 
is completely independent of your working set (General), or you can generate 
a summary graph of fire occurrence data that is contained in your working set 
(Working Set).

To review fire occurrence data by generating summary graphs

1 On the Fires menu, select Summary and then click General.

2 The Select Fires and Year for General Summary dialog box will open. 
Select a Region, and any Units, Sub Units and Years.
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3 To verify that only the desired fire associations are selected, click on the 
Fire Associations button and select View Selections. The “#####” 
indicates that there is no working set association.

4 Click OK.

5 Click on the Years tab to open the Select Fires and Years for General 
Summary dialog box. Use the Start Year and Finish Year drop-down 
menus as shown to select the start and end years of your choice.D R
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6 To review the fire occurrence data, click on the View Fires button.

The following diagram shows the fire occurrence data for 1996 through 2006.

To sort by any field, right-click on the column heading of your choice. To 
adjust column width, drag the column heading to the desired width. 

7 Close the Edit Fire Occurrence Data screen to return to the Select Fires 
and General Summary dialog box.
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8 To generate the Fires Summary graph, click Fire Summary -> OK.

The following diagram shows the frequency distributions of total fires and 
acres by year, fires by month, fires by size class, fires by cause class, and 
number of fires per fire-day for the Northern Region of the Forest Service.

.

To review the working set fire occurrence data by generating 
summary graphs

Verify the working set for years and annual filter. 

1 From the main tool bar click Fires -> Summary -> Working Set.D R
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Or, alternately you can click on the Fires Summary Working Set icon on the 
main toolbar.

2 The Select Fires for Summary screen will open. In the Region column, 
at least one region must be highlighted for at least one agency. In the 
Unit(s) and Sub Unit(s) columns, if a unit is marked, only marked rows 
are selected. If no rows are marked, all rows associated with the parent 
region or unit are included. The following example shows selection of 
USFS, Northern Region, and Nezperce National Forest (all districts).

The example below shows the selection of USFS, Northern Region, Kootenai 
National Forest and only the Libby Ranger District.

3 To view your complete selection criteria and to verify that only the 
desired fire associations are selected, click View Selections. You should 
see a screen similar to the following. This example shows fire 
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associations for USFS, Northern Region, Kootenai National Forest, and 
Libby Ranger District.

4 View fire occurrence data by clicking on the View Fires button. 

5 You can sort by any column (right-click on the column header), or use the 
three icons at the upper left to export, print, or delete records. 

Hint: The export button allows you to export to a text file or to an ESRI 
shapefile.

6 Finally, to generate the Fires Summary graph, click OK. A Fire 
Summary Graph is created as shown.
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With the Fire Summary graph open, you can review fire size and cause by 
selecting Options -> View Class Definitions. The Fire Size and Cause 
Class Definitions report window will open as shown below.
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With focus on the Fire Summary graph window, you can review Graph Data 
by selecting File->View Graph Data.

Note: The information shown below is displayed diagramatically. The 
actual format of the information you will see on your screen differs 
somewhat from this example.

Fire Associations:

01 Rexford RD

05 Libby RD

Year      Fires        Acres

2000         79      26142.4

2001         46        158.0

2002         59         10.2

2003         77         59.2

2004         42         18.7

2005         68        844.2

2006        125        134.7

Total       496      27367.4

Month    Fires   Lightning     Human

 1            0           0         0

 2            0           0         0

 3            0           0         0

 4            0           0         0

 5           27           4        23

 6           43          18        25

 7          151          41       110

 8          224         157        67

 9           38          14        24

10           13           0        13

11            0           0         0

12            0           0         0

 (fires are tabulated by total/lightning/

human)

Size Class     Fires

A                   379

B                    98

C                    11

D                     1

E                     4

F                     0

G                     3
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Remember to use the Data Years drop-down menu in your Working Set 
window to match the desired years of fire data coverage.

Using the Event Locator
The Event Locator allows you to locate, count, and list dates of specified 
weather events that occur on a single day or over consecutive strings of days. 
You can use the Event Locator to search for events or combinations of events 
based on weather values and/or calculated indices. The Event Locator is 
useful for searching for rare occurrences or for checking for bad or erroneous 
data. 

For example, as a fire manager, and with the help of local expertise, you must 
decide what kind of weather will stop fire spread. An event is a single item or 
combination of weather and NFDRS parameters that meet your specified 

Cause Class      Fires

1                    234

2                     12

3                     17

4                    145

5                     15

6                      6

7                     17

8                      8

9                     42

Num Fires    Fires per Day(297 Fire-Days)

 1                    205

 2                     62

 3                     12

 4                      2

 5                      4

 6                      4

 7                      4

 8                      1

 9                      0

10+                     3

Fire Size Percentiles Distribution

Percentile   Size (Acres)

 69               0.1

 70               0.2

 75               0.2

 80               0.3

 85               0.5

 90               1.2

 91               1.5

 92               2.0

 93               3.0

 94               4.4

 95               5.0

 96               8.5

 97              12.0

 98              25.0

 99             785.0

100           11115.0

The Fire Size Percentiles Distribution (left panel) is not 

displayed graphically. It gives the fire size cumulative dis-

tribution for the current analysis set. Notice that the “low” 

percentile are ignored and do not start until fire sizes of 0.1 

acres. From whatever that point may be, the results are 

tabulated by 5 percentile increments to the 90th percentile, 

then by 1 percentile increments from the 90th to 100th 

(largest fire). This is a way to assist in determining values 

to use for “candidate” large-fire thresholds.
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conditions. You can define these conditions as those that occur on a single 
day, or those that occur over a string of consecutive days.

The Event Locator allows you to:

• Find dry spells, such as periods of time when there was no rainfall.

• Inspect the database for suspect data, such as listing the days when the 
wind exceeded 50 miles per hour.

• List five-day periods where .2 inches or more of rain fell, thus causing a 
fire-ending event.

The Event Locator allows you to use the following categories to identify 
particular values:

• Sum: The summed, or total, of the variable.
• Avg: The average of the variable for the period.
• Min: The minimum value in the string.
• Max: The maximum value in the string.
• Daily: The daily value in the string.

To use the Event Locator

1 Click on Weather -> Event Locator. 

The Event Locator dialog box will open as shown.D R
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2 Set the Period Length by typing in a number in the box as shown. The 
Period Length is the length (in consecutive days) that is required to 
match the criteria in the query table. For this example, type in “5.”

The Event Locator Period Length is independent from the Analysis Period 
Length of the Working Set. However, the Data Years and Annual Filter in 
the Working Set do limit data used by the Event Locator.

3 Fill in the first row of the Event Locator query table. (You may enter up 
to three rows). Each row is one condition on a Fire Family Plus analysis 
variable. Click in the field area to obtain a drop-down menu for each field 
option. In the following example, Precipitation Amount has been 
selected.

4 Select a Category from the drop-down menu provided. In this example, 
“Sum” has been selected.

5 Next, choose an Operator and Value. In the following example select >= 
and 2.00.

6 Select a Value Type from the drop-down menu. 

The Value Type defines whether the value is a “fixed” value or the value 
of a variable at a fixed percentile level. Percentile values are dependent 
on the current working set definition (years, annual filter, fuel model, etc.).

7 Click Add Row.

8 Finally choose an appropriate Operator for constructing your query. You 
must select either AND or OR to combine the conditions. Select AND 
and complete the Event Locator dialog box as shown.
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9 Click OK when the dialog box is complete. 

This example searches for a 5-day total of 2.00 or more inches of rain and a 5-

day average ERC below or equal to the 80th percentile. 

For this Working Set, the 80th percentile is 18.00. As shown below, there are 
nine occurrences of these events.
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To search for erroneous data - an example

This example explains how to search for precipitation amounts greater than or 
equal to 5 inches per day.

1 On the Weather drop-down menu, click Event Locator.

2 In the Period Length (Days) box, type 1 and then press TAB twice.

3 In the Variable box, select Precipitation Amount, and then press TAB.

4 In the Category box, select Min, and then press TAB.

5 In the Operator box, select >=, and then press TAB.

6 In the Value box, type 5.0 and then press TAB.

7 In the Value Type box, select Value, and then click OK.

The following diagram shows the Event Locator dialog box for searching for 
daily precipitation amounts greater than 5 inches.

 
Event Definition: 
    Sum(Precipitation Amount) >= 2.00 
    AND Avg(Energy Release Component) <= 80.00 Percentile (18.00) 
 
         5-Day Periods 
 
DATE         Rain    ERC 
-------------------------- 
05/31/1999    2.40   7.60 
09/27/2000    2.49   7.00 
10/09/2001    2.50   5.00 
05/26/2004    2.03   0.00 
07/15/2004    2.01  17.60 
08/21/2004    2.09   4.20 
09/10/2004    2.52   3.80 
10/29/2005    2.23   0.20 
11/02/2006    2.64   1.20 
 
9 hits out of 4657 
2391 rejects for no/missing observations 
 
FF+4.0 11/06/2008-14:37 
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The following diagram shows the resulting FireFamily Plus Events report for 
weather station “101028.”
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To search for a fire-ending event - an example

This example explains how to search for five-day periods with precipitation 
amounts greater or equal to .2 inches. The fire is assumed to start on August 
5th on the Nez Perce National Forest, in an area that is well-represented by 
the Moose Creek weather station, “101028.”

1 On the File drop-down menu, click Open and then select the active 
Working Set of your choice.

2 In the beginning Month and Day boxes, select August 6.

3 On the Weather menu, click Event Locator. The Event Locator dialog 
box shown below will open.

4 In the Period Length (Days) box, type 5.

5 In the Variable box, select Precipitation Amount, and then press TAB.

6 In the Category box, select Sum, and then press TAB.

7 In the Operator box, select >=, and then press TAB.

8 In the Value box, type .20 and then press TAB.

9 In the Value Type box, select Value, and then click OK.

The following diagram shows the Event Locator dialog box for determining 
five-day periods of precipitation amounts greater than or equal to .2 inches.

The following diagram shows the resulting Events Report.D R
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The rain may have all fallen on the first day, all on the last day, or somewhere 
in between. Note that several season-ending events have occurred within a 
single year.

Be certain of your active working set. If it defines only a subset of your data, 
the computed percentile may not reflect what you really want. 

To use the Event Locator on a data subset and a percentile-related value as 
your threshold criteria, generate a statistical table to determine that threshold, 
then enter it in the Value box in the Event Locator dialog box. For more 
information, see “Reviewing weather data and generating reports,” earlier in 
this chapter.

To perform a more complex query - an example

In this example, you will add ERC as a variable to check the season ending 
date, given that the maximum ERC during that five-day period with rain 
remains below the 67th percentile.

1 On the Weather menu, click Event Locator.

2 In the Period Length (Days) box, type 5.
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To add a new row, click Add Row. To delete a row, press REMOVE ROW.

3 Click the Operator arrow, select AND, and then press TAB.

4 In the Variable box, select Energy Release Component, and then press 
TAB.

5 In the Category box, select Max, and then press TAB.

6 In the Operator box, select <, and then press TAB.

7 In the Value box, type 44 and then press TAB.

8 In the Value Type box, select Value, and then click OK.

The following diagram shows the completed Event Locator dialog box that 
allows you to determine five-day periods when ERC is no more than 44 and 
precipitation is .2 inches or more. 

The following diagram shows the resulting Events report of Selected Events 

for weather station “101028” for the Annual Filter dates of May 1st through 

December 31st.
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.

If you are unsure whether the date represents the end of season or which 
date to use, generate an ERC graph and create an overlay of the year of your 
choice. If the ERC remains low, you have found the season ending date.

For more information about determining the ERC and weather percentile for 
the previous example, see Chapter 7, “Working with fire analysis tools,” later 
in this guide.D R
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Using the NFDRS Calculator
The NFDRS calculator is a tool that allows you to calculate NFDRS indices 
based on the information you enter. Although you must have FireFamily Plus 
version 4.0 installed on your computer, you can use the NFDRS calculator by 
itself or in conjunction with other fire analysis software applications. The 
NFDRS calculator allows you to:

• Perform NFDRS sensitivity analysis.

• Compare outputs between fuel models, such as comparing fuel model 
“A” to “B” or the years “78” with “88.”

• Calculate Keetch-Byrum Drought Index (KBDI). Review and compare 
parameters among fuel models.

To use the NFDRS calculator

1 Click NFDRS Calculator on the FireFamily Plus toolbar.

You can also click on the NFDRS Calculator on the Weather menu.

2 Select the Fuel Model and Slope Class of your choice by using the drop-
down menus provided.

3 Check the Use 88 Model box if appropriate.

4 Fill in the Temperature (in degrees F), 20’ Wind (mph), and SOW text 
boxes as appropriate.

Remember that Temperature and SOW (State of the Weather) affect 
Ignition Component, whereas 20’ Wind affects Spread Component (SC) 
and Burning Index (BI).
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5 Type in the values or use the spinner to select the Fuel Moistures for the 
selected fuel model.

Moisture classes that are unavailable for the selected fuel model appear 
dimmed.

6 Complete the 88 Model Inputs if appropriate.

7 If you wish to view or compare fuel model parameters, click on the Fuel 
Model Parameters button (lower left) to bring up the following dialog 
box. Here you can select a fuel model. Each time you click Add to Table 
a row is added to the table with the model parameters. The example below 
shows the differences in the 1978 and 1988 Fuel Model D - Southern 
Rough. The information table is available as long as the Calculator 
application is open.

8 If you know the KBDI value you want to use, you can enter it directly in 
the 1988 Inputs section of the NFDRS Calculator dialog box.
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Or, you can click on the KBDI Calculator button and enter the required 
inputs. The cumulative precipitation value (Cumulative Precip) is used to 
determine if the first 0.20 inches of the current day rainfall is subtracted from 
the net effective rainfall. Cumulative precipitation is set to zero any day there 
is no rain. If there is rainfall of 0.05 inches five days in a row, the cumulative 
precipitation value would be 0.05, 0.10, 0.15, 0.20, and 0.25 on days 1, 2, 3, 4, 
and 5 respectively. In computing the KBDI, the net effective rainfall would 0 
on days 1, 2, 3, and 4, and 0.25 on day 5. The KBDI will be calculated and 
transferred to the input box for 88 Model Inputs when you click on Apply. 
When finished click Calculate.

9 When finished entering all values, click Calculate on the NFDRS 
Calculator dialog box.D R
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Chapter 7.  Working with fire analysis tools

This chapter explains how to view and interpret combined weather and fire 
occurrence data using the fire analysis and decision points tools of FireFamily 
Plus. These tools will help you perform a variety of fire analysis functions, 
including:

• Performing cumulative and probability fire analysis.

• Evaluating cumulative fires analysis graphs.

• Evaluating fires probability analysis graphs.

• Setting decision points.

• Reviewing the decision points graph.

• Changing decision points to reflect fire business.

• Working with fire business candidates list.

As you read this chapter, keep in mind that FireFamily Plus allows you to:

• Interpret danger indices by relating danger indices to fire activity based 
on a percentage or probability basis. In addition, you can use fire analysis 
to select an appropriate fuel 

• Choose the most appropriate fuel model and index. FireFamily Plus tools 
offer an objective way to evaluate the many indices and fuel models.

• Evaluate representative weather stations. By comparing fire activity in a 
management area to indices that are based on weather data from several 
area stations, you can determine which stations are most representative of 
fire business.

• Set better decision thresholds. Historically, critical levels for an index 
have been defined from percentile levels without regard to fire activity. 
By integrating weather and fire activity, you can better determine 
percentile levels to suit a variety of fire management needs.

Performing cumulative and probability fire analysis
This section explains how to use FFP to generate graphs that identify 
statistical relationships between weather indices and fire occurrence. These 
relationships are established by fire associations with a weather station. For 
every day of weather, the following is determined: 

• Was a fire discovered? If so, the day is marked as a “fire day.”

Click here to generate
a Fire Summary graph. Click here to Set

Fires Analysis
Options.D R
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• If a day is marked as a “fire day,” did any fire discovered on that day 
exceed your definition of a large fire? If yes, the day further denoted as a 
“large fire day.”

• If a fire day is identified as a “fire day,” were more fires than defined by 
your multiple fire day limit discovered? If so, the day is further 
designated as a “multiple fire day.”

This determination creates four distributions: “All Days,” “Fire Days,” “Large 
Fire Days,” and “Multiple Fire Days.”

The Interactive Batch function in FireFamily Plus 4 (See Chapter 12) allows 
you to quickly review these relationships among stations, SIGS, weather/
indices and fuel models. The analysis principles are the same as described 
here.

Note: You should always review the working set parameters 
(stations, dates, and fire associations) before using fire analysis 
tools. Also make sure you have fire occurrence history for each of 
your weather years. For example, if you had weather data for the 
period 2000 to 2008 but only fire history for the years 2000 to 2007, 
the analysis years should be 2000 to 2007. Having no fires (as 
opposed to no data) is valid. For example if no fires occurred in 
2005 the analysis years of 2000 to 2007 are valid.

The examples shown in this chapter use Energy Release Component (ERC) 
which reflects a good fire business indicator for our sample data set. Your 
weather and fire occurrence datasets may not show strong correlations. You 
will want to analyze several fuel models and indices when preparing your 
analysis

The following diagrams show the example working set and fire associations 
used in this chapter.
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To perform cumulative and probability fire analysis using ERC

1 On the FireFamily Plus toolbar, click on Fires -> Fires Analysis.

The following Fire Analysis Options dialog box will open. In the example 
shown below, the Energy Release Component is selected as the Analysis 
Variable.

2 Check the appropriate Fire Cause radio button (the usual choice is “All”).

3 Define the Fire Definitions thresholds by typing in desired values 
directly or by using the spinner.
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Values for these definitions are based on local experience and 
results from using your fire occurrence summary statistics as 
described in Chapter 6.

4 Select an Analysis Type using the radio buttons provided. (The usual 
choice is “Both”).

5 In the Analysis Variable drop-down list, select Energy Release 
Component.

6 The Conditional Probability Analysis check box controls the sample 
size of the large, and multiple fire day analysis. With the box unchecked, 
all days are included in the large and multiple fire day analysis. Checking 
the box creates a conditional probability analysis. That is, only weather 
days with fires are included in the large and multiple fire day analysis 
probability. 

7 Click OK when the dialog box is complete.

The Cumulative Fires Analysis window displays frequency distributions of 
the four groups of weather days (as defined above) in two ways. The left panel 
shows frequencies as simple histograms (absolute frequencies). The right 
panel shows cumulative frequencies (percentiles). The distributions are: 

• All Days regardless of fire activity - white.

• Fire Days - blue.

• Large Fire Days - purple.

• Multiple Fire Days - red.

Once you get a feel for what you are looking for, you may find that 
the best way to “screen” indices is to perform a Cumulative 
Analysis first, and then perform the Probability Analysis on your 
best indices.

D R
 A

 F T
7.5 June, 2009



FireFamily Plus User’s Guide Chapter 7. Working with fire analysis tools
Evaluating the histogram

The maximized left panel shows absolute frequencies (day counts) in a 
histogram.
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• All Days - white. ERC ranges from 0 to about 80 and 31 days had ERC = 
0. Most ERC's fall between 20 and 45 or so.

• Fire Days - blue. There were no fire days with ERC less that about 6; and 
just a few up to about ERC = 25. Between ERC 30 and 60 fire days were 
pretty evenly distributed.

• Large (purple) and Multiple (red) Fire Days begin to occur at ERCs of 
approximately 30 with most occurring above an ERC of 55 or so. But 
these trends can be difficult to see on these graphs and maybe easier to 
interpret on the Cumulative Percentile graph (right panel).

Evaluating the cumulative distributions

Use the following guidelines to evaluate the four frequency distributions in 
the graph.

• When lines are horizontal, there are no weather days in that range.

• When lines approach vertical, there are many days in that range.
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• If lines are on top of each other, there is no difference in the distributions, 
and you can infer that the index contains no information to discriminate 
fire business. 

• If the lines are nicely spread out you can infer that the index has value in 
discriminating fire business.

• Sharp changes of inflections in the fire (fire/large/multiple) day lines may 
indicate index ranges or values that could be useful starting points for 
developing decision thresholds.

The maximized panel on the right shows the Cumulative Fires Analysis 
graphs for ERC.

In the example shown:

• All Days - black. ERC values range from 0 to about 80.   The histogram 
shows that 31 days had ERC = 0, (approximately 2 percent of the total 
number). Most ERC values fall between approximately 20 and 45 (the 
steepest part of the black line). 

• Fire days - blue. There were no fire days with ERC values less that 
approximately 6; and just a few up to about ERC = 25. Between ERC 30 
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and 60, fire days were more or less evenly distributed. (Note that the blue 
line changes slope at ERC = 25 and slope is constant to ERC = 60). The 
separation of the curve (blue to the right of the black indicates that fire-
days tend occur on higher ERC days than do non-fire days. This is good.

• Overall, large (purple) and multiple (red) fire days have similar 
distributions (lines are similar) but since both lines are to the right of fire-
days, this indicates that large and multiple fire days tend to occur on days 
with higher ERC than do fire days (fires occur but not large fires). 

Because the number of large and multiple fire days is (usually) small 
compared to weather and fire days, those lines are not smooth. Each vertical 
“bump” can indicate 1 or 2 fire days. In this example, we see that there are 
(essentially) no large or multiple fire days when ERC is below 30. The 
inflection point at ERC=50 on the Large Fire Day line is a good illustration of 
where large fire risk changes. Between 40 and 50 there were few large fire 
days (but a steady rate of fire days). Above an ERC of 55, the frequency of 
large fire steadily increases even though the frequency of weather days with 
ERC is small (the black curve flattens out). If you follow the intersection of 
ERC=55 with the All Day line, you will notice that an ERC of 55 is about the 
80th percentile; only 20 percent of all days have ERC values greater than 55.

The “tailing off” of multiple and large fire days at the highest “fire danger” 
values is not unusual. Remember that prevention programs kick in at high fire 
danger. And in the west, very high ERC's mean prolonged hot and dry periods 
(high pressure) which translates into no lightning - the cause of 60 percent of 
fires in our example.

When you review the Cumulative Fires Analysis graphs, remember that fire-
days started picking up above an ERC value of 25. The logistic model 
reinforces this interpretation.

Evaluating Fires Probability Analysis graphs

Based on your fire associations, Fires Probability Analysis takes every 
historical weather day, including date and index value, and assigns each day 
as a:

• Fire-day (yes/no)

• Large fire-day (yes/no)

• Multiple fire-day (yes/no).

FireFamily Plus performs a logistic regression for each fire-day type, to 
generate charts and goodness of fit statistics. 

Note: The Conditional Probability Analysis check box controls the 
sample size of the large, and multiple fire day analysis. If the box is 
unchecked, all days are included in the large and multiple fire day 
analysis. Checking the box creates a conditional probability analysis, that 
is, only weather days with fires are included in the large and multiple fire 
day analysis probability. In the example below there are 1454 weather 
days and 387 fire days. In the first Large-Fire Day analysis, all 1454 days 
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are used, in the second, only 387 fire-days are used. The first analysis 
gives the probability of a given index range of a large fire day, whereas 
the second analysis expresses the probability, given a fire start on a day 
in that index range. The conditional analysis usually has a lower Chi 
Square score and a very different probability distribution, particularly in 
the low range of the index. 
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The chart is the easiest to interpret. The lines are models produced by the 
logistic regression on the data (e.g. the probability of a fire-day as a function 
of ERC). The color-associated symbols near the line are essentially the data 
(fraction of observed fire-days for a range of the index). If the symbols are on 
or near the line, the model fits the data well, if not, it doesn't.

In this example, fire-days begin increasing above an ERC of about 20. The 
logistic model reinforces this interpretation. Notice how the blue line's 
inflection changes around and ERC of 50 and the symbols jump from 
approximately a 10% fire-day rate to almost 30%.

You can also perform conditional probability analysis for large fire and 
multiple fire days.

Logistic regression is ideal for “yes/no” types of data.

The following diagram shows an ERC Fires Probability Analysis graph for 
Libby Ranger Station 240107 (Montana).
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A horizontal line at 50 percent tells you that there are no occurrences of 
large fire-days or multiple fire-days in your analysis.

Our final goal in evaluating the Fires Probability graph, is to discern a good 
index from a bad one in terms of its ability to describe fire business. To do 
this, we look at two qualities:

• Range of probabilities over the range of the predictor variable:

- 10 percent at the low end to 90 percent on the high end is very good. 
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- 10 percent at the low end to 15 percent on the high end doesn't tell us 
much.

• Distribution of predictor variables:

- A wider range (0 - 100) allows more flexibility in setting levels.
- A narrow range (12 - 22) may make setting levels harder.
- Avoid having 90 percent of observations in one/two classes.

When you've screened out all of the bad indices, use goodness-of-fit statistics 
to determine your best index. 

There are two statistics to test goodness-of-fit in the text report:

“Chi Square,” - a lower value is better.

“R-Squared,” - a higher value is better.

Review both graphs to understand any relationship in the data. If you have 
determined that you have an index that contains some good information about 
fire business in your analysis area, it makes sense that you would want to set 
some sort of decision points based in part on the index (see “Setting the 
Decision Points,” in the following section for more information).

For a complete discussion of the analysis of indexes, refer to:

Andrews, Patricia L. and Larry S. Bradshaw. “FIRES: Fire Information 
Retrieval and Evaluation System - a Program for Fire Danger Rating 
Analysis” at:

http://www.fs.fed.us/rm/pubs/int_gtr367/index.html

Setting decision points
This section explains how to set action or danger class limits based on both 
fire weather and fire business in your danger rating area. Before you begin, be 
sure that your working set is correctly configured, including years, dates, and 
fire associations.

The Decision Points button on the FireFamily Plus toolbar is only active 
and available when displaying a Fires Probability Analysis graph.
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The Class Lower Limits dialog box displays the initial breakpoints that 
divide the data into five classes. These initial breakpoints are set using 
roughly the same logic as is used for setting the Adjective Classes in WIMS 
and allows you to adjust the breakpoints and add or delete classes.

To set decision points

1 On the Fires drop-down menu, click Fires -> Fire Analysis.

2 To generate the Fires Probability Analysis graphs, click Probability 
Analysis, select the Analysis Variable of your choice, and then click 
OK.

3 Click the Decision Points button on the toolbar. 

You can also click Decision Points on the View drop-down menu when 
the Conditional Probability graph window is open.

Class Lower Limit

1 Zero

2 1/4th of the index’s 90th percentile value

3 1/2 of the index’s 90th percentile value

4 The index’s 90th percentile value

5 The index’s 97th percentile value
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To see more clearly, maximize both the FireFamily Plus and Decision Points 
windows. Then move the Class Lower Limits box so that it does not obscure 
the graph.

The chart below shows the relative frequency of the four weather type days: 
All Days, Fire-Days, Large Fire-Days, and Multi Fire-Days. The bar chart 
on the top shows all day-types combined.

In the Decision Points window, you can view the Class Lower Limits box 
by clicking on Tools -> Class Definitions.
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The initial screen divides the data into five classes. The initial breakdown 
points (lower limits) of these five classes are set using the same logic that is 
used for setting staffing levels in WIMS (Weather Information Management 
System).

Class 1: zero

Class 2: 1/4 of the value of the index's 90th percentile (10.75)

Class 3: 1/2 of the value of the index's 90th percentile (21.5)

Class 4: The value of the index's 90th percentile (43.)

Class 5: The value of the index's 97th percentile (50.69)

To expand the graph of your choice, click, hold, and slide the bars 
accordingly.
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To view discarded fires

1 From the Fire Probability Analysis graph, click Discarded Fires on the 
View drop-down menu.

The following diagram shows a list of Discarded Fires.

Reviewing the Decision Points graphs
You are already familiar with the contents of the two graphs on the left side of 
the window since they are exactly the same as the ones you previously 
generated and studied for purposes of decision making.
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The vertical lines in these graphs demonstrate where class boundaries fall 
along the percentile or probability curves. The right panel in the window is 
quite simple. It shows the relative frequency of the four weather type days 
(All Day, Fire-Day, Large Fire-Day, and Multiple Fire-Day) within each class. 
The top right panel shows all day-types combined, the four lower graphs 
simply split them out so you can easily compare the relative frequency of day-
types as you go between classes.

If you would prefer to view a table, the top panel offers a table format. The 
columns marked with asterisks--%, %FD, %LFD, and %MFD--are shown in 
the bar charts in the right panel of the graph window above. The table is 
updated each time you click on Apply.
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The following diagram shows the Decision Points table that is located on the 
upper left portion of the Decision Points window. You can modify this table 
and the Percentile and Probability graphs by applying new decision points.

These graphs contain considerable information and all of it is interconnected. 
Take a few minutes to review your graphs before continuing.

Changing decision points to reflect fire business
Now that you have reviewed the Decision Points graphs, you can change the 
values in the Class Lower Limits dialog box to adequately reflect fire 
business. The following list outlines how your bar charts should look and 
why:

• As fire danger moves from Class 1 to Class 5, you should see a steady 
increase in the risk of large and multiple fire days.

• As fire danger moves from Class 1 to Class 5, the ratio of days to large 
fire days should decrease.

• As fire danger moves from Class 3 to Class 4 and to Class 5, the 
percentage of large fire days and multiple fire days should not decline. 
Ideally, these fire days would increase.

There is no exact recipe for success in this process. You will need to look at 
the graphs and determine what makes sense. You can modify the graphs by 
changing the decision points in the Class Lower Limits dialog box.

For bar charts, ideally:
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• The risk of large and multiple fire-days increases steadily as fire danger 
increases from Class 1 to Class 5.

• The ratio of days to large fire-days should decrease as you move from 
Class 1 to Class 5.

• The percentage of large fire-days and multiple fire-days should not 
decline as you move from Class 3 to Class 4 to Class 5. (The percentage 
should increase).

The dotted lines above each of the bar charts shown above illustrate trends for 
these charts. What needs to be changed in these examples?

• The proportion of Fire-Days in Class 3 (70%) is too high.

• Large Fire-Days and Mult Fire-Days do not show an upward trend from 
low to high.

How you change these class limits should be directly related to the 
information contained in the Probability and Percentile curves. Look at the 
Probability vs. ERC curves. The Class 3 lower limit is currently at the point 
on the Fire-Day curve where it begins to rise steeply, indicating that the 
probability of a fire is increasing faster as the ERC rises. Location where the 
curves change directions are good decision points. Also note that the Large-
Fire and Multi-Fire curves are just starting an upward trend. Therefore the 
Class 3 decision point is in an appropriate place and does not need to be 
changed.
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To change the class lower limits

To include more Large Fire-Days and Multi Fire-Days in Classes 4 and 5, we 
need to reduce the lower limits of those classes (the decision points). To 
change classes you should modify the Class Lower Limits dialog box as 
shown below. Change the Class 4 lower limit to 36, and the Class 5 lower 
limit to 45. Then click the Apply button.

You are not limited to five classes. You may add or delete classes 
with the New and Delete buttons. Experiment with other Analysis 
Variables and different numbers of classes. D R

 A
 F T
7.21 June, 2009



FireFamily Plus User’s Guide Chapter 7. Working with fire analysis tools
D R
 A

 F T
June, 2009 7.22



Chapter 7. Working with fire analysis tools FireFamily Plus User’s Guide
Notice that the bar graphs have a more reasonable distribution of Fire-Days, 
Large Fire-Days, and Multi Fire-Days. The probability and cumulative curves 
also tell us that the historical risk of large- and multiple fire-days is quite low 
at ERC values less than 20. 

FireFamily Plus version 4.0 allows you to view fires rejected from the fire 
day probability analysis as a separate window. For more information, see 
the next section, “To view discarded fires.”

When reviewing the Decision Points graphs, consider the following:
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• Differentiate each class from the class above or below it for different fire 
business.

• Ensure that each class has a significant increase of risk, perhaps even 
twice the risk.

• Use the minimum number of classes you need to support decisions and 
actions.

Working with the fire business candidates list

Developing a list of potential fire business indices

FireFamily Plus (see Chapter 12 for more information) allows the user to 
develop a list of potential fire business indices using the candidates table. 

While in the Interactive Batch Mode, if you find a good potential index of fire 
activity based on a fires analysis report or graph, press the button labeled C+ 
to add the index to the candidates table. Several indices can be rapidly added 
for comparison.

1 To add an index to the fire business candidates table for later comparison, 
click the C+ button. 

2 All statistics will be added to the table for the current working set 
description and can be viewed using the Fires -> Fire Business 
Candidates.
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Viewing candidates list

1 Select Fires -> Fire Business Candidates.

2 Review the fire business candidates list.

The following diagram is an example of the Fire Business Candidates table 
showing index statistics added using the Add Candidates button in the 
Interactive Batch mode.
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3 You can view the table for only Fire Days (FD), Large Fire Days (FD), or 
Multiple Fire Days (MFD) by checking the boxes in the upper left corner 
of the dialog box.

4 You can sort any of the columns by right-clicking the column header and 
selecting Sort Ascending or Sort Descending. The right most column is 
available for entering user comments about the variable.

5 Every entry into the Candidates List is saved in the active database until 
explicitly deleted using the Delete, or Delete All buttons.

6 You can also export the table to a comma-delimited text file that can be 
imported into a spreadsheet program such as Microsoft Excel (see 
example below). 
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If you click on Export, the file will be saved automatically to the 
FireFamilyPlus4 folder.
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This chapter explains how to generate and work with a pocket card. Topics 
include:

• Identifying years of interest, fires, and index values.

• Generating a pocket card.

A pocket card is a safety tool that identifies key information about a specific 
fire danger area. Fire Family Plus allows you to generate a pocket card at any 
time to increase firefighter awareness of current local conditions.

Identifying the years of interest, fires, and index values
Use the climatology reports and fires analysis information generated in 
Chapters 6, “Working with reports and graphs” and 7, “Working with fire 
analysis tools,” to determine and define which two years of interest, indices, 
and thresholds you need to create a meaningful pocket card.

Start FireFamily Plus, open the default database and create a Working Set. 

• Select the Libby weather station (240107).

• Select all available data years.

• Limit the annual filter to the fire season (May 1 through September 30).

Select an NFDRS index value and fuel model for the pocket card based on 
your prior examination of seasonal trends of various indices and fires 
analysis.

• In this example, ERC appears to be useful and BI is often used for 
staffing.

• Fuel model G is the primary fuel model used for the Libby station. Make 
sure that the Station Metadata uses the “G” model.

Burning Index (BI) is often used for staffing decisions.

To determine the years of interest for comparison

Next we will select years of interest for comparison by looking at the fire 
history.

1 On the Main Menu click Fires -> Summary -> Working Set or click on 
the Fire Summary Working Set icon on the toolbar.
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2 Click on the USFS tab and make sure that the Northern Region and 
Kootenai Forest are highlighted.

3 Click OK.

The following window should open showing the Fire Summary for the Libby 
weather station (240107).
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Based on the Fire Summary graph, 2000 and 2006 have significant burned 
acres and would be good choices to use as “Years to Remember” for the 
pocket card.

Generating the pocket card
After completing the background analysis you can generate a meaningful 
pocket card to highlight local conditions.

To generate a pocket card

1 On the FireFamily Plus toolbar, click Weather -> Pocket Card or click 
on the Pocket Card icon. The Pocket Card dialog box will open as 
follows:

2 Type or select Fire Danger Area (in this case, type in “Northwest 
Montana”).

3 If desired, select an Area Locator Bitmap using the Browse button to 
locate the file. The bitmap may consist of a bitmap graphic that shows the 
area location, a logo, or even a photograph. This step is optional. In the 
following example, a bitmap of northwestern Montana is selected.

4 Select a Fire Danger Index from the drop-down menu (use “Energy 
Release Component”).
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5 Select the Years to Remember (for this example we have selected 
“2000” and “2006”).

If your working set does not include the current year, but there is current 
year data in the database, you can select the Year to Date check box to 
enable a third overlay.

6 Year to Date: If your working set does not include the current year, but 
there is current year data in the database, the Year to Date box will be 
enabled as a third overlay. (The current year will not be included in the 
statistics (mean, max., or min. lines).

The example does not include current year data, therefore the check box 
is grayed out.

7 To select a fire for comparison, click Find in the appropriate Fires list, 
and then double-click the fire of your choice in the Select a Fire dialog 
box. Up to three fires can be plotted on the Pocket Card graph, but they 
must be from the “Years to Remember.” (In this example, 2000 and 
2006).

You can select up to three fires for comparison, but they must have 
occurred during the “Years to Remember.”

8 Type in the Area Locator Bullets (in this example, type in Line 1: 
“Northwest Montana;” Line 2: “Fire Wx Forecast Zone 104;” and Line 3: 
“Libby Weather Station”).

9 Select Local Thresholds (in this example, a) Wind Speed 15; b) Relative 
Humidity: 25; c) Temperature: 90; and d) Live Fuel Index: 100).
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10 Type Past Experience text. Include information specific to this area as 
well as any general and key points to remember (for this example, type in 
“Large fire activity can occur when the ERC exceeds 45”).

11 Check the box in the lower left corner if the station meets NWCG 
Weather Station Standards.

See http://www.fs.fed.us/raws/standards.shtml for information on Weather 
Station Standards.

12 Fill in the box for responsible agency. The example shows “Montana 
DNRC.” Select the available fields and data format as described above.

13 When finished, click OK.

The following diagram shows a sample Pocket Card screen.

The following diagram shows the generated pocket card.D R
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The following website includes example pocket cards from across the 
U.S. available for review as well as information on items to include in 
pocket cards: http://fam.nwcg.gov/fam-web/pocketcards/default.htm.

To print a pocket card

1 On the File menu, click Print.

2 In the Name list, click the color printer of your choice.

3 To change the page orientation, click Properties, click Landscape, and 
then click OK.
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To change the background pattern of your pocket card

This option allows you to change the visual appearance of your graph. Look 
carefully at the readability of the lines in your graph and what these 
background colors denote. For example, don't use red to denote the lower 
portion of your graph if the index value is low or moderate. On humidity and 
fuel moisture graphs where low represents a higher fire danger, the colors will 
be inverted.

FireFamily Plus will invert the colors for humidity and fuel moisture graphs 
where low represents a higher fire danger.

1 In the Pocket Card dialog box, click Graph Background.

2 Change the Vertical Percent fields as desired (for the example use a) red/ 
yellow: 80; b) yellow: 0; c) yellow/green: 20), and then click OK.

The following Graph Background dialog box shows the background settings 
that were used to create the sample pocket card.
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3 Click on OK to export weather data.

To save a pocket card

1 On the File drop-down menu, click Save As.

2 In the File name text box, type the file name of your choice, select the file 
format of your choice, and then click OK.

You can save the pocket card in .bmp, .png, .jpg, .gif, and .tif formats. 
Select the file format that best suits your needs.
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Chapter 9.  Working with fire danger projections

This chapter explains how to generate medium range fire danger projections 
based on current year-to-date weather. It also outlines several techniques for 
developing fire weather scenarios. Topics include:

• Understanding generated fire weather records from climatological 
percentiles.

• Reviewing the active working set.
• Generating fire danger projections.
• Generating reports and graphs.

 

You can create projected observations using one of the following:

• Blank fire weather observations.

• Persistence of the last year-to-date fire weather observation in the 
working set.

• Fire weather observations generated from climatological percentiles from 
your active working set, which includes stations, years, and annual filters.

To successfully create projected observations, you must have year-to-date 
observations in your active working set for the stations of interest.  The 
current year must be part of your active working set.  You can edit your 
projected observations, although these are not saved as part of your 
database.

Understanding generated fire weather records from 
climatological percentiles

Generated fire weather records use historical, individual daily percentiles of 
temperature, humidity, and wind speed. This differs from the percentile for 
the entire working set. For example, if your period length is one day, there is 
one observation for each year in the working set. Therefore, a working set that 
contains 20 years of data contains 20 observations for each day from which to 
select the percentile. As compared to the overall critical percentile, this value 
is the same as plotting the seasonal values of critical percentiles on a 
statistical graph.

To generate projected observations from the 60th percentile of temperature for 
July 1 to July 15, for example, FireFamily Plus examines the working set for 
the 60th percentile for the observed dry bulb, and maximum, and minimum 
temperatures for each of the 15 days. If you select the 10th percentile of 
humidity, FireFamily Plus examines the working set for the driest 10th 
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percentile of observed, maximum, and minimum relative humidities for each 
day. Similarly, by selecting 50th percentile winds, FireFamily Plus will 
calculate the median value of wind for each of those 15 days. 

You can project hot dry conditions by selecting high percentile values for 
temperature and low percentile values for humidity.

Projected observations from percentile weather have precipitation amount, 
duration, and state of the weather initialized to “no precipitation” and “mostly 
sunny skies,” where state of the weather equals “1.”  It is up to you to create 
precipitation events, if desired, for your medium range projections.

Reviewing the active working set
The following figure shows the active working set used for the examples in 
this chapter. Notice that observation data for the current year 2008 is available 
and selected in the working set. Since there are no observations for the year 
2008 during the projections period, the projected observations you generate 
from historical percentiles will be based on daily observation data from 1990 
through 2007.

You can project fire danger indices for other analysis period lengths and for 
Special Interest Groups (SIGS).
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Generating fire danger projections
This section explains how to generate NFDRS indices from your projected 
observations. You can also generate projections from climatology and obtain 
the percentile values for temperature, humidity, and wind.

To start the fire danger projection module

1 On the FireFamily Plus toolbar, click on the Fire Danger Projection 
icon.

Just as when you generate a statistical table or graph, FireFamily Plus 
automatically synchronizes your active working set when you click on Fire 
Danger Projections.

The following diagram shows the Fire Danger Projections dialog box. 
Notice the starting date in this example is July 28, 2008 which indicates that 
the active working set has data for the Red Rocks station through the 28th of 
July, 2008.

To select the fire danger projection options

1 Click Options >>>.
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Based on the indices you selected for your projection, select variables as 
desired for the Output Columns. The following diagram shows the 
Projection Options dialog box. 

2 Use Options -> Graph Options to modify the graph as needed. (See 
Chapter 6 for additional information). The New Day WX Values option 
in the Projection Options dialog box allows you to select the method you 
would like to use to create observations. Selections are: Same as 
Previous Day, Blank, or Use Historic Daily Percentiles. 

Graph Display Options dialog box allows you to distinguish the format of 
the projection line from the year-to-date and other overlays on the 
statistical season graph. You can also modify the projection line once you 
create the statistical season graph by clicking the Fire Danger 
Projections tab on the Graph Options dialog box.
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3 Click on the Fire Danger Projections tab as shown.

The following dialog box will open. 

4 Select the Line Color, Width and style options you would like to apply.

Although you can select only one New Day WX Values option at a time, you 
can create several days of persistence, and then switch to a climatology 
sequence before clicking the Calculate button on the Fire Danger 
Projections dialog box.

In this example, you will generate the following projections:

• Temperature based on the 70th percentile, which is slightly above the 
median.

• Humidity at the 10th percentile, which is slightly below the median.
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• Wind speed based on the 50th percentile.

For this example, if you selected the Same as Previous Day option, every 
new record would be the same as July 27th, 2008.

To add days of projected weather data

1 Click Add Day for each day of projected weather data.

The following diagram shows the Fire Danger Projections beginning July 

28th, 2008. Notice that the daily observations vary slightly, there is no 
precipitation, and the State-of-the-Weather (SOW) values are all set to “1.”

You can add days up to the end of the Annual Filter as defined in your working 
set.

State of the Weather (SPW) codes showing percent cloud cover include:

0 clear (0.0 - 0.1) 5 drizzling
1 scattered clouds (0.2 - 0.5) 6 raining
2 broken clouds (0.6 - 0.9) 7 snow/sleet
3 overcast (100% obscured) 8 showering
4 foggy 9 thunderstorms in progress

To remove a record from your list of fire danger projections

1 Highlight the record of your choice.
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2 Click Remove Last Day.

To modify the weather for a specific date

1 Highlight the record of your choice, and then modify the appropriate 
fields as desired.

The following diagram shows cloudiness (SOW=2) for July 30th through 

August 1st, and three hours of rain (0.05 inches) for July 30th.

2 When satisfied with your projection strings, click Calculate.

The following diagram shows the calculated outputs for your fire danger 
projections. D R
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From here, you can change, delete, or add the projected observations and 
recalculate as desired.  You can also change the projections options.

Generating reports and graphs
This section explains how to generate reports and graphs from your 
projections.

To generate reports and graphs from your projections

1 In the Fire Danger Projections dialog box, click Reports & Graphs at 
the lower right. The Select Outputs to Generate dialog box opens as 
shown. D R
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2 In the Available column, highlight the variable(s) of your choice, and 
then click >>>> to move that variable to the Selected column. To 
generate a graph for every available variable, click Select All.

3 To generate a text file of the projected weather and indices, check 
Generate Report.

4 To generate the reports and graphs, click OK.

After generating the reports and graphs, you can return to the Fire Danger 
Projections dialog box and edit your projection strings.

If you select the Close Forecast Window check box, FireFamily Plus will end 
your current projection session and return to your active working set after you 
generate the reports and graphs. To continue to edit your projection strings 
without starting all over again, be sure to clear this check box.

The following diagram shows the initial window appearance after your Fire 
Danger Projection run is complete.D R
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FireFamily Plus reprocesses the working set to obtain any potential overlay 
years and then displays a window for each graph object you selected. These 
windows appear behind the Fire Danger Projections window.

The following diagram shows the Energy Release Component Statistics 
Graph window. Here, the heavy dashed line represents projected ERC based 
on your generated projection strings.D R

 A
 F T
June, 2009 9.10



Chapter 9. Working with fire danger projections FireFamily Plus User’s Guide
To create an overlay on your statistical projections graph

1 On the Options menu, click Overlays. The Set Overlay Options dialog 
box will open as shown.D R
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2 Click New, then select the Year, Color, and Width, and Line Style for the 
overlay.

3 To review the appearance of the overlay, click Apply.

4 When finished adding new overlays, click OK.

Be sure to check the “Enable Auxiliary Years Overlays” box on the 
working set screen to use this option.
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Chapter 10.  Performing hourly data analysis

This chapter explains how to work with hourly weather data. Topics include:

• Viewing hourly observations.
• Generating hourly listings.
• Generating diurnal graphs.
• Exporting hourly weather data to FARSITE.
• Using the Hourly Event Locator.
• Working with the Nelson Dead Fuel Moisture model.

As elsewhere in FireFamily Plus, your hourly data analysis results are 
controlled by how you configure your active working set. The best way to 
determine the type of hourly data you have, is to select your station/SIG in 
the working set and select Weather -> View Observations -> All.

To support hourly analysis you should import files from National Interagency 
Fire Management Integrated Database (NIFMID) that are in the standard 
FW9 format (See Appendix D for additional information). The FW9 file 
format has several observation types, including:

• O type. A 1300 hour NFDRS record with State of the Weather (SOW) 
and wet flag.

• R type. An hourly weather observation record without State of the 
Weather.

If a station in your active working set contains “R” type observations, you will 
be able to choose from the Hourly Data Analysis options on the Weather 
menu. If no stations contain “R” type observations, these options appear 
dimmed and are not enabled.
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Viewing hourly observations
The View Observations option on the Weather menu allows you to view 
either daily observations (1300 NFDRS type “O” observations) or all 
observations in your active working set.

To view all observations in your working set

1 On the Weather drop-down menu, point to View Observations.

2 Click All.

The following diagram shows all observations in the default FireFamily Plus 
database (ffplus4). Notice the buttons available on the toolbar.

Recall that the working set is a filter of the active database (see Chapter 5 
for additional information).
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To save (export) observation records to your computer

1 Click the Export Data icon and select the file format of your choice.

2 Save the file in a folder of your choice.

The following diagram shows the Export Weather Data to a Text File 
dialog box. From here, you can export weather data and save it in a variety of 
formats.
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To delete a range of observations from your active working set

1 Select the record of your choice, and then click the Delete Records icon. 
The Delete Records dialog box will open.

2 In the Start Record box, type or select the first record of your choice.
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3 In the End Record box, type or select the last record of your choice.

4 When finished, click OK.

5 To confirm the delete, click OK. The following diagram shows the 
warning message for deleting weather observations from your active 
working set.

Hint:  To delete all records you can put a huge number for the “End 
Record” value.

To sort the weather observations

1 Right-click on the column of your choice, and then select either Sort 
Ascending or Sort Descending.

The following diagram shows the Weather Data listing as it appears when 
you right-click on the Temp(F) column.

.
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To increase a column width

1 Position the pointer in the column heading of your choice, and then drag 
to the right or to the left to increase or decrease the column width.

You can also increase or decrease the height of any row using this same 
method.

To print the weather observations in your working set

1 Click the Print Table icon.

2 Select Options and Available Fields of your choice.

3 Click OK when you have competed your selections.

The following diagram shows the Select Fields to Print dialog box.

Since you are dealing with hourly data, printing these files may require vast 
quantities of paper! Be sure that printing all is what you really want to do!

Generating hourly listings

To generate an hourly listing

1 On the Weather drop-down menu, point to Hourly Data Analysis, then 
click Hourly Listings.
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The following diagram shows the Select Output Variables for Hourly 
Listing dialog box.
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2 Select the General, Data Format, and Time Format options of your 
choice.

3 In the Available Variables column, highlight the variable(s) of your 
choice, and then click >>>> to move that variable to the Selected 
Variables column. To generate an hourly listing for every available 
variable, click Select All.

4 To generate the hourly listing, click OK.

To change the order of your selected variables, highlight the selected 
variable(s) of your choice and then click the up and down arrows 
to move the selection up or down. 

The following diagram shows the resulting hourly listing for Dry Bulb 
Temperature, Relative Humidity, and Wind Speed.D R
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Generating diurnal graphs
The Diurnal Graphs option allows you to determine the hourly average 
value for all days in your active working set. It also allows you to generate a 
companion report of the average value for each hour for each day of the year 
(not for each day of each year). 

Each variable you select will produce one graph and report.

There are no overlays or graphic configuration options for diurnal graphs.

The diagram below shows the active working set used for most of the 
examples that follow in this chapter.D R
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.

To generate a diurnal graph

1 On the Weather drop-down menu, click on Hourly Data Analysis, and 
then click Diurnal Graphs.

The following Generate Diurnal Graphs dialog box will open.
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2 In the Available Variables column, highlight the variable(s) of your 
choice, and then click >>>> to move that variable to the Selected 
Variables column. To generate diurnal graphs for every available 
variable, click on Select All.

3 To generate the diurnal graphs, click OK.

The following diagram shows the resulting Wind Speed Diurnal Analysis 
output.
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The report on the left displays the average value for each day in the working 
set. 

The graph on the right displays the “0000” through “2300” hourly averages 
for all days in the working set, which is essentially the average of each 
column in the report.

The graph may not always display the precise average of each column in the 
report. The report does not display the number of observations for each day/
hour, which may vary from cell to cell. 

The following diagram shows the resulting Mode Wind Direction graph. 
Instead of a numerical average, the mode direction identifies the direction that 
occurs most often.
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“Wind direction” is classified according to the eight standard wind directions 
in a fire weather observation, where 0 = Calm, 1 = NE, 2 = E, and so on.

Remember, this summary is based on your active working set.

To save your diurnal reports and graphs

1 On the File menu, point to Save, and then click Report or Graph.

2 Type a name of your choice and then click Save. Reports are saved using 
the .txt file extension. Graphs can be saved in a variety of file formats 
(.bmp, .png, .jpg, .gif, or .tif files).

If report options are comma-delimited, the report can be saved as a *.csv 
file and imported into an Excel spreadsheet.D R
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Exporting hourly weather data to FARSITE
The FARSITE Exports option allows you to automatically create FARSITE 
export files from your active working set, (one file for each day). These files 
are compatible with FARSITE version 3 and greater. You can use FireFamily 
Plus version 4.0 to directly export fire weather observations to initialize fire 
growth projections using FARSITE.

Select a period of weather from a specific year from your climatology analysis 
for FARSITE simulations. 

To create a FARSITE export file

1 On the Weather drop-down menu, click on Hourly Data Analysis, and 
then click FARSITE Exports.

2 The FARSITE Datafiles dialog box will open. Click on the Select FarSite 
File Types check boxes of your choice.
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3 Click >>>> to browse to the folder location of your choice and then type 
the File Name of each export file.

4 After clicking OK, your selected reports will be displayed. The exported 
files will be properly formatted for immediate use in FARSITE and 
FlamMap.

You can save the export files shown above in any folder you choose. 

The following diagram shows the layout of the export weather file (.WTR) for 
FARSITE version 3. This weather file has one summary record per day. The 
fields are month, day, precipitation amount, time of minimum temperature, 
time of maximum temperature, minimum temperature, maximum 
temperature, maximum relative humidity, minimum relative humidity, and 
station elevation (expressed in feet).

The following diagram shows an example wind export file (.WND). It 
contains an hourly listing for each day in the working set range and identifies 
month, day, hour/minute, wind speed, direction (azimuth), and cloud cover.
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Cloud cover is “0” unless rain occurred during the hour. If rain occurred, cloud 
cover is set to “100.” In this example, no rain occurred.

Using the hourly event locator
The Hourly Event Locator functions much like the Event Locator described in 
Chapter 6. However, instead of using daily data, the Hourly Event Locator 
uses hourly data. If you have hourly data, you can use the Hourly Event 
Locator to query the database for weather events lasting a specific minimum 
number of hours. You can use it to locate, count, and list periods of specified 
weather events that occur within a single hour or over several consecutive 
hours.

For example, it allows you to:

• Find periods of potential extreme burning conditions.

• Find events such as a brief period of heavy rain or high winds.

• Inspect the database for suspect data.

The Hourly Event Locator allows you to use the following categories to 
identify particular values:

• Sum: The summed, or total, of the variable.

• Avg: The average of the variable for the period.

• Min: The minimum value in the string.

• Max: The maximum value in the string.

• Hourly: The hours value in the string.

To search for erroneous data - an example

The Hourly Event Locator functions in much the same way as the Event 
Locator described in Chapter 6.

This example explains how to search for precipitation amounts greater 
than or equal to 1 inch of rain in a single hour.

1 On the Weather drop-down menu, click Hourly Data Analysis and 
select Hourly Event Locator.

2 In the Period Length (Hours) box, type 1 and then press Tab twice.

3 In the Variable box, select Precipitation Amount, and then press Tab.

4 In the Category box, select Sum.

5 In the Operator box, select >=, and then press Tab.

6 In the Value box, type in 1.0 and then press Tab.

7 In the Value Type box select Value, and then click OK.
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The following diagram shows the Hourly Event Locator dialog box used to 
search for hourly precipitation amounts equal to or greater than 1 inch.

The following Events report shows individual 1-Hour Periods receiving 1 
inch or more of precipitation.

To search for a run of extreme burning conditions - an example

The following example shows how to look for periods of hours of extreme 
burning conditions.

1 On the Weather drop-down menu, click Hourly Data Analysis and 
select Hourly Event Locator.
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2 In the Period Length (Hours) box, type 4 and then press Tab twice.

3 In the Variable box, select Dry Bulb Temperature, and then press Tab.

4 In the Category box, select Hourly.

5 In the Operator box, select >=, and then press Tab.

6 In the Value box, type in 85.00 and then press Tab.

7 In the Value Type box select Value, and then click OK.

8 Complete the box as shown below.

9 When the dialog is completed, click OK.

The following example from the Red Rocks station in Montana (245410) 
shows extreme burning conditions meeting the conditions of your search.
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The Nelson Dead Fuel Moisture Model
The Nelson Dead Fuel Moisture Model is driven by hourly precipitation, solar 
radiation, temperature, and relative humidity, and eliminates the need for 
user-defined state of the weather (SOW) inputs. The model runs on hourly 
data and can be defined for any size-class of fuel. It is a physical model of 
moisture gain and loss in dead fuel, and it has been shown to be a better 
predictor of fine dead fuel moisture than the original NFDRS logic. There are 
two options for the Nelson Deal Fuel Moisture analysis in FireFamily Plus 
version 4.0: “Hourly Values,” and “Compare with daily NFDRS.”
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Hourly Values

The hourly values listing will produce a report of the hourly fuel moistures for 
each of the four NFDRS dead fuel size classes. It includes the hourly data 
used to calculate the moistures as well as a summary of the settings for that 
run. When you choose the hourly values report from the menu, you will first 
be prompted for startup values for each size class. If you have good 
measurements of fuel moisture for the startup period, enter them in the dialog 
box. Otherwise accept the defaults which are based on station climate class, 
and select OK.

Once you have pressed OK, in the Nelson Dead FM Parameters dialog box, 
the model will calculate the fuel moisture values and display both the 
meteorological data and the derived moisture values in tabular format as 
shown. 
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Compare with daily NFDRS 

The second option for calculating Nelson Dead Fuel Moistures in FireFamily 
Plus is the “Compare with daily NFDRS” option. This option displays both 
the Nelson Dead Fuel Moistures and the traditional NFDRS-based fuel 
moisture calculations to allow for comparison of these differences for 
calculated ERC, SC, IC, and BI. It is important for users to become familiar 
with this feature because it builds an understanding of the potential influence 
of the new fuel moisture model on the calculated indices. The report is similar 
to “Hourly Values” but adds summaries of the traditional NFDRS moisture 
values. The columns at the left side of the report show indices with the 
traditional method. The Nelson moisture driven calculations appear on the 
right. These data can be exported into a spreadsheet for further analysis by 
clicking the Save icon at the upper left on the toolbar.
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Chapter 11. Batch functions

Version 4.0 of FireFamily Plus introduces new “batch” functionality. This 
chapter explains how to work with batch functions in FireFamily Plus. Topics 
include:

• Creating a new batch.
• Managing a batch list.
• Saved run maintenance.

In order to understand and use FireFamily Plus batch functions, you should 
become familiar with two terms: runs and batches.

• “Runs” are stored almost anytime you generate a report in FireFamily 
Plus as long as the Batch -> Enable Run Saving option is selected.

• “Batches” are collections of two or more “Runs.”

Note: Importing data is not considered a “run.”

To facilitate building batches, FFP runs may be saved in the active working 
set database. Runs are numbered sequentially. All of the parameters in the run 
(stations, SIG, data years, seasonal filters, overlay years, etc.) are saved. 
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Once in the saved database, these runs can be used to: 

• Build batch jobs consisting of one or more saved runs, or 

• Restore run settings and run FireFamily Plus in the “classic” mode. When 
running a batch, output can be sent to the screen (“flying windows”) or 
auto-saved to a disk.

To save a run

Run saving is toggled on and off by clicking on Batch -> Enable Run Saving 
in the Batch menu.

Creating a new batch

To create a new batch

1 Click on Batch ->Create new batch and the following dialog box opens:D R
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.

This dialog box can be used to identify a new batch run that you would like to 
create from previously saved runs. 

2 Check the runs that you would like to include by selecting the boxes to the 
left of the boxes in the Include? column. 

3 Add a description of your batch run in the box provided under 
Description.

4 Use the Select All button at the bottom of the dialog box to include all 
previously saved runs shown. 

5 Click on Deselect All to uncheck all runs. 

6 When you have completed your selection, click on Create batch. You 
may cancel (click on Cancel) at any time.

When you have completed your selection, the following box will appear.D R
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7 Click on Create now or Cancel.

A new batch will be created from your saved runs. The following dialog box 
verifies that the batch has been created.

If you have many saved runs, you can filter and sort by SIG or Station 
name or by description (such as “Climatology” or “Daily Listing”) for ease 
of locating a run.

Maintaining and running batches

To manage a batch list

1 Select Batch -> Manage batch list from the drop-down menu as shown 
to open the following Batch Management dialog box.D R
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. 

2 Next you will need to select the batch you want to run or maintain from 
the Batch Management dialog box.

You can choose from the following options:

• Run Classic: Runs all reports in the batch and creates many, many 
windows in the FireFamily Plus application.

• Run Auto-Save: Runs all reports, but saves all reports and graphs to a 
location that you specify (see “Run Auto-Save” on page 11.6).

• Create new: Allows you to create a new batch as described.

• Edit/View: Allows you to view and edit (add or delete Runs).

• Delete: Allows you to delete a batch.

Run classic

If you select Run Classic, you will see the following progress bar as your run 
proceeds.D R
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After the run is complete, numerous windows open in the FireFamily Plus 
application as shown below:

Run auto-save

If you select Run Auto-Save, reports are saved as set in Options -> Batch/
Run Options -> Batch Auto Save.

To select batch options

1 Click Options -> Batch/Run Options.D R
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2 The following Batch/Run Options dialog box will open. (The dialog box 
shown in the example is open to the General batch options tab).

3 The General batch options tab allows you to override the default “Run” 
description as runs are saved. You can add custom descriptions to your 
saved runs. 
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4 If the Prompt for a description before each report box is checked, you 
can edit the run description before every run as shown below.   Or, you 
can select the default description. If this box is not checked the custom 
description is used and you cannot modify it.

5 Click on the Batch AutoSave tab in the Batch/Run Options dialog box 
to save images to a location of your choice. Click the Browse for folder 
button to navigate to a directory/folder. (See section 6.18 for additional 
information). 
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6 Set the resolution if necessary.

7 Use the drop-down menu shown below to select a file type from the 
options available.

8 Click OK to continue.D R
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You will see a completion window noting the initial directory of the batch 
files. The following dialog box shows an example of a FFP completion 
window.

In this example, reports are saved in subdirectories Run1 and Run3 since 
those are the runs in the batch.

File names are self-generated by FireFamily Plus and cannot be edited 
by the user. They should be decipherable by the report (or file) name.

All Batch Autosave files are overwritten in subsequent executions of the 
same batch run.
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Saved run maintenance

Maintenance is completed by selecting the Batch -> Saved run 
maintenance... option which opens the Saved Run Maintenance dialog box. 

This dialog box can be used to: 

• Disable run saving (no runs will be saved until it is turned back on).

• Select the Number of Records to be included in the database that you 
will save.
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• Select the Least Recently Used runs (a specified number of runs will be 
saved, but runs which have not been used recently will be deleted as 
newer ones are added). 

Runs that you have accessed within the last two weeks will not be 
deleted.

• Specify that no archiving scheme will be used.

You can toggle Enable Run Saving on or off. If you wish to limit the number 
of runs saved in the database uncheck the box.

You can also delete all runs using the Purge all saved runs and batches 
button or remove only selected runs by clicking on Manual Run 
Maintenance at the bottom of the Saved Run Maintenance dialog box.

Click on Purge all saved runs and batches and the following dialog box 
opens.

Click OK, only if you are certain that you would like to delete all information.

Manual run maintenance

Manual run maintenance is both flexible and useful. This feature allows you 
to view the basic run information, including information on whether the run is 
used in any batches. You can delete all runs or only selected runs. 

1 Click on Batch -> Saved run maintenance.D R
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2 Click on the Manual Run Maintenance button at the bottom of the 
dialog box. 

3 The Manual Saved Run Dialog box will open as shown.
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4 Select the runs you wish to delete by checking the boxes in the Delete 
column at the left of the dialog box.

Restore settings from a previously saved run

1 Select Restore previous run settings from the Batch drop-down menu.

2 If Enable Run Saving is checked on the Batch drop-down menu as 
shown above, subsequent restored runs will create new RunIDs in the 
database, even if you do not make any changes. If Enable Run Saving is 
off (not checked), runs will not be saved.

3 The following Restore settings from a previously saved run dialog box 
will open. 
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4 Select a RunID and click the Load settings button to confirm your 
selections. The following dialog box will open.

5 Click OK. When you click on OK, the run parameters are restored. This 
option will set the working set, annual filters, and analysis period from the 
previous run. 

The working set will be established from the settings for the selected Run.

The following dialog box confirms that settings have been restored.D R
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Chapter 12.  Interactive batch

This chapter explains how to work with the Interactive Batch function in 
FireFamily Plus. Topics include:

• Using the interactive batch function.
• Making changes in the interactive batch session.
• Using interactive batch icons on menu bar.

The initial NFDRS parameters (Fuel Models) are taken from the station 
metadata in the station catalog. This is editable through the Working Set 
dialog in the SIG/Station metadata box or by selecting Data -> Stations (or 
SIGS) -> Edit.

Using interactive batch
Interactive Batch allows you to select any number of stations and SIGS, and 
run all reports for all weather variables and indices.

To use interactive batch

1 Click Batch -> Interactive.

2 The following dialog box will open.
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3 Use the Select SIGS/Stations dialog box to select the SIGS and/or 
Stations of your choice.

4 When you have made your selections, click Run to begin the interactive 
batch process.

5 You will see the following FireFamily Plus Progress box indicating that 
the run is proceeding.

When the run is finished, you can view reports of your choice. Results are 
displayed in a dialog window with a row for each selected SIG/Station and 
columns for each FFP report. The right/left arrows access additional report 
tabs.

D R
 A

 F T
June, 2009 12.2



Chapter 12. Interactive batch FireFamily Plus User’s Guide
Expanding the Station (or SIG) by clicking on “+” displays groups of 
variables - Weather, NFDRS, and CNFDRS.

Expanding the Weather tree displays the weather variables as shown below.

Expanding the NFDRS tree displays the US Fire Danger variables.D R
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Finally, expanding the CNFDRS tree displays the Canadian Fire Danger 
variables.

Click on Burning Index and the Stats Graph tab opens that report in the 
main window.
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At the beginning of an interactive batch session:

• All data for selected Station/SIGs are processed and initially displayed. 
The data years, annual filters, and analysis periods in the “normal” 
working set windows are ignored.

• The NFDRS fuel model parameters in the “normal” working set are used.

• Most changes made to Interactive Batch working set definitions and 
options are saved in the “normal” working set, but not all. 

Once the interactive batch output window is open, several new icons appear 
on the toolbar and become active.

D R
 A

 F T
12.5 June, 2009



FireFamily Plus User’s Guide Chapter 12. Interactive batch
When you select an icon and modify the values, results are updated in all 
reports.

Changes you can make in the interactive batch session

Using the toolbar icons in the Interactive Batch mode you can make the 
following changes:

• Change NFDRS parameters. Clicking on this icon opens the Special 
Interest Group Attributes or Station Information dialog box. Changes 
made here are applied only to the currently viewed Interactive Batch 
station/SIG and are updated in the base working set for that station or SIG.
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• Reset the Working Set. Changes made here are applied only to currently 
viewed Interactive Batch Station/SIG. It appears that the “last” set values 
of data years and analysis periods are updated in the “classic” working set 
for that station/SIG, but the annual filter is not. Remember, however, that 
if you change the analysis period from “1” day to “10” in the Interactive 
Batch, the 10-day grouping will be ignored the next time you use this 
station in interactive batch. It will be applied in the standard (or non-
interactive batch) mode.

.

• Update Graph Options. Changes made here are applied to all checked 
stations/SIGs in the Interactive Batch session and are updated in the 
“classic” working set for those stations/SIGs.
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• Change overlays. Changes made here are applied to all checked stations/
SIGs in the Interactive Batch session and are updated in the “classic” 
working set for those stations/SIGs.

• Modify the Fire Associations. Changes made here are applied only to the 
currently viewed Interactive Batch station/SIG and are updated in the 
“classic” working set for that station/SIG.
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• Modify Fire-Day Parameters (Fire Options). Changes made here are 
applied only to the currently viewed Interactive Batch stations or SIGs 
and are updated in the “classic” working set for that station/SIG.

• Add Goodness of Fit Statistics to a Candidates Table (Add to 
Candidates List). This icon allows you to add the selected variable in a 
batch run to the “Fire Business Candidates List.” 

This information is also available through the classic Fires Analysis. Data 
-> Add to Candidates List.

• When viewing the statistics from a Fires Analysis report, you can add the 
goodness of fit statistics to an FFP table called “Fire Business 
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Candidates” by clicking on this icon. Almost all of the information about 
the model run is stored along with the goodness of fit statistics. 

Information kept in the Candidates List can be examined by selecting 
Fires -> View Candidate List  (see Chapter 7).

You can view the accumulated model candidates from Fires -> Fire Business 
Candidates when the working set window is active. This can be viewed from 
Interactive Batch but is not restricted to it.

Changes made to metadata in Interactive Batch are not reflected in the 
master station catalog metadata. That is, if you start with model “A,” and 
in Interactive Batch change to model “G,” the “A” model is still the master.

In the Fire Business Candidates table you can limit the fire-type statistics 
(fire-day, large fire-day, or multiple fire-day), delete rows, and export the 
table to a .csv file to open directly in a spreadsheet program. You can also sort 
on columns and add comments to a row (far right column).D R

 A
 F T
June, 2009 12.10



Chapter 12. Interactive batch FireFamily Plus User’s Guide
D R
 A

 F T
12.11 June, 2009



FireFamily Plus User’s Guide Chapter 12. Interactive batch
D R
 A

 F T
June, 2009 12.12



Chapter 13.  Exporting data

This chapter explains how to export data while working with FireFamily Plus. 
Topics include:

• Exporting station metadata.
• Exporting SIGs station metadata.
• Exporting fire data.
• Exporting weather data.

Exporting data

Exporting station metadata

Station metadata can be exported to a text file.

1 Select Data -> Station from the menu bar.

2 The following Weather Stations dialog box will open, showing the 
choices to export.

3 Select the Station(s) for which you would like to export metadata and 
click Export list.

4 The Export Station Metadata dialog box will open as shown.
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5 Select the fields you wish to export from the Available Fields column and 
move them into the Selected Fields column.

6 Select the data formats of your choice (“Field Delimiter,” “Data 
Format,” and “Time Format”).

7 Click the Export text file button after you have made your selections and 
specify the file name and location.

The following is an example of a station metadata export. 

Since the file is “comma-delimited” in this example, you can export it into a Microsoft Excel spreadsheet 
as shown.

FireFamily Plus Station Metadata Export 
   printed on: 04/19/2007   at  03:04:25 PM  (from run # 34) 
   using database: C:\Documents and Settings\lbradsha\My Documents\ffp4_data\ffp4_default 
 
Station ID,Name,Latitude,Longitude,Elevation,Station Type,Site 
#,State,County,Agency,Region,Unit,NFDRS fuel model,Use 88?,Climate class,Slope 
class,Aspect,Position on slope,Herb annual?,Greenup date,Freeze date,Herb moisture,Shrub 
moisture,Initial KBDI,Deciduous?,Avg. precip,Initial 1000h,FM 1=10 ? 
015902,OPNPND,  31.09444, -86.54861,275,4,1,AL,Covington,USFS,09 Eastern Region 
(R9),CONECUH,C,Y,3,1,4,,N,,,,,624,Y, 62.00, 25.00,Y 
040611,REDDING,  40.51579,-122.29220,500,4,1,CA,Shasta,,,NWS,B,N,2,1,0, ,Y,04/24,11/01,,,100,N, 
33.00, 15.00,N 
245410,RED ROCKS,  44.69917,-111.82330,6690,4,1,MT,Beaverhead,USFS,01 Northern Region 
(R1),BDF,G,N,3,1,5, ,N,05/23,10/15,,,0,N, 10.00, 25.00,N 
245415,FRENCH CREEK,  45.33000,-112.91310,7422,4,3,MT,Beaverhead,USFS,01 Northern Region (R1),B-
D,G,N,3,3,5,,N,05/05,05/05,,,100,N, 14.50, 25.00,N 

D R
 A

 F T
June, 2009 13.2



Chapter 13. Exporting data FireFamily Plus User’s Guide
Exporting SIGs

The same export functionality is available for stations in SIG groups.

1 Select the SIG you would like to export. Click Data -> SIGS.

2 Click Export.

3 Select the available fields and data format as described on pages 13.1 and 
13.2.

4 Click the Export text file button after you have made your selections.

5 Specify the file name and location.
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Exporting fire data

1 To view fires select Fires ->  Summary -> General (or -> Working Set).

2 Highlight the units of your choice.

3 Click View Fires.

4 You can export the currently selected fires by clicking on the Export 
Data (Save) icon located at the upper left corner of the Edit Fire 
Occurrence Data dialog box. 

When the Export Data (“Save”) icon is selected, the following Export Fire 
Data dialog box will appear.

5 Select the fields you wish to output from the Available Fields column.

There are two export options in the Export Fire Data dialog box. The first 
option (Export text file) will export the data as a simple text file. The second 
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option (Export ESRI shapefile shp/shx/dbf) exports the data as a shapefile 
that can be used in GIS applications. 

6 The Save As dialog box will open. Select the type and location of the 
export file.

Exporting weather observation records

While viewing weather data you can export observation records in a manner 
similar to that used for fire data. 

1 Select Weather -> View Observations.

2 The Weather Data dialog box will open as shown.

3 Click Export Data (or the Save icon) at the upper left corner of the dialog 
box.

4 Select the file format of your choice and save the file in a folder.

5 The following diagram shows the Export Weather Data to a Text File 
dialog box. The dialog box allows you to export weather data and save it 
in a variety of formats.
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6 Select the export format, Field Delimiter, Data Format and Time 
Format.

7 Choose the variables of your choice from the Available Fields column.

8 After completing all of your selections, click OK to open the SaveAs 
window and export weather data.
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Appendix A.  Retrieving NIFMID data using 
KCFAST

This appendix explains how to use the Kansas City Fire Access Software 
(KCFAST) to download information into FireFamily Plus. KCFAST allows 
you to extract weather and fire occurrence data and station catalog 
information from the National Interagency Fire Management Integrated 
Database (NIFMID). Topics include:

• Accessing KCFAST.

• Retrieving weather, fire occurrence, and station catalog data.

• Downloading files from the ftp site to your personal computer.

Accessing KCFAST
KCFAST is available on the Fire and Aviation Management web page by 
selecting KCFAST from the menu at the left of the page

http://fam.nwcg.gov/fam-web/

You must have a valid WIMS/NIFMID logon ID and password to retrieve 
data from NIFMID. For more information, send your request to 
fire?@fs.fed.us.

To access KCFAST from the Internet

1 Start your Internet browser. 
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2 In the address box, type http://famweb.nwcg.gov then press Enter.

3 Click KCFAST.

After accessing this web page, you can save time later by adding this 
address to your browser as a bookmark.

To setup your WIMS/NIFMID logon ID for KCFAST retrievals

1 From the KCFAST Main Menu, click Setup.

2 Type your Username and Password, and then click OK.

3 Your Username is in the format:

   ops$[WIMS/NIFMID logon id]

For example, "ops$fs1234" is a valid Username.

4 Type your Email address, and then click Submit.

The following User Profile Information screen shows a sample Email address.
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Retrieving weather, fire occurrence, and station 
catalog data

There are three basic types of data that you can retrieve from NIFMID:

• Historical fire weather data identifies data collected from specific 
weather stations.

• Fire occurrence data identifies data collected from the U.S. Forest 
Service.

• Station catalogs identify key weather station information.

Be sure to select “Send file to ftp site” when retrieving weather data from 
KCFAST. Currently, FireFamily Plus does not reliably import raw file 
occurrence files retrieved with a browser 

To retrieve historical fire weather data

Although historical fire weather data is either saved in “72” format or “98” 
format, you will request most of your retrievals in the “72” format.

1 From the KCFAST Main Menu, click Weather.

2 Click Data Extract, and then click Historical.

3 Type the Station ID, and then Begin and End date range.

4 Click Raw Datafile - 1972 Data Format.

5 Select the E-mail notification option of your choice, and then click 
Submit.

The following Historical Fire Weather Data Extract screen shows a 
retrieval for station 101221 and spanning the month of July, 1995.
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The following screen shows a sample FTP REQUEST CONFIRMATION 
message for station ID “050505.”

Write down the file name so that you can locate this file when you access the 
site ftp2.fs.fed.us.

To retrieve US Forest Service fire occurrence data

1 From the KCFAST Main Menu, click Fire.

2 Click Standard Extract.

3 Type the two digit Region and two digit Forest numbers.

4 Type the Begin Year and End Year Date Range.

5 Click NFMAS - PCHA (PC Historical Analysis).

6 Click Raw Datafile.

For more information about RAW and FPL data layouts, click Datafile 
Definition.

7 Select the E-mail notification option of your choice, and then click 
Submit.

The following Fire Occurrence Data Extraction screen shows a retrieval for 
Region 04, Forest 8 and spanning the years 1985 through 1996.
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The following screen shows a FTP REQUEST CONFIRMATION message.

8 Write down the file name so that you can locate this file when you access 
the site ftp2.fs.fed.us.

To retrieve station catalog information for a single station

1 From the KCFAST Main Menu, click Weather.

2 Click Station Catalog, and then click Station Information.
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3 Click BY SINGLE STATION, and then type the desired Station ID.

4 Click Send file to FTP site.

5 Select the E-mail notification option of your choice, and then click 
Submit.

The following Weather Station Information screen shows a station 
information retrieval for station “1012211.”

Downloading files from the ftp site to your personal 
computer

In KCFAST, retrievals are named so that you can easily identify each file and 
its contents. For example, you can identify a KCFAST weather observation 
retrieval as follows:

D R
 A

 F T
June, 2009 Appendix A.6



Appendix A. Retrieving NIFMID data using KCFAST FireFamily Plus User’s Guide
If you choose, you can rename KCFAST retrievals when you download the 
file. Use the following list as a guideline:

For record layouts of RAW and FPL files, follow the procedure outlined on 
page 2.4, “To retrieve U.S. Forest Service fire occurrence data.” For step 
6, click Datafile Definition.

Before downloading fire weather, fire occurrence, and station catalog 
files, you can better organize your retrievals by storing them in separate 
folders. For example, to store weather observation files, create the folder 
“fsapps/fam/ FireFamily Plus/FWX files.” To store fire occurrence files, 
create the folder “fsapps/fam/FireFamily Plus/RAW files.”  To store a 
working set database, create the folder “fsapps/fam/FireFamily Plus/MDB 
files.”

To download a file from ftp2.fs.fed.us

1 Start your Internet browser. 

2 In the address box, type ftp://ftp2.fs.fed.us/incoming/wo_fam then press 
Enter.

3 Right-click the file name of your choice, click Copy to folder, then 
double-click the folder of your choice.

Table 1: 

[forestname].fpl for fire occurrence files at the forest level, 
minus the fire name

wx[stationID].fwx for weather observation files in the 72 format

wx[stationID].fw9 for weather observation files in the 98 format

[forestname].raw for fire occurrence files at the district level, 
including fire name, in the full FS5100-29 
report format

[name].txt for text files to be imported into FireFamily 
Plus.

D R
 A

 F T
Appendix A.7 June, 2009



Appendix B.  Using FireFamily Plus with rerap

The Percentile Weather report allows you to select a variable and a wind 
direction for preparing a Rare Event Risk Assessment Program (RERAP) 
report. For example, given an ignition in an area approved for wildland fire 
use for resource benefits, you can use historical weather records, fuels, and 
weather conditions to calculate the probability of the fire being pushed to a 
particular point of concern.

To generate a Percentile Weather report

1 On the Weather menu, click Season Reports, and then click Percentile 
Weather.

The Percentile Weather Analysis Variable dialog box will open. The 
following diagram shows Energy Release Component selected as the 
percentile weather analysis variable.

2 Use the Analysis Variable drop-down list to select the desired variable, 
and then click OK.

The resulting diagram combines many RERAP calculations into one screen.
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FireFamily Plus User’s Guide Appendix B. Using FireFamily Plus with rerap
3 Check the desired Wind Direction(s) that would move the fire toward 
any points of concern.

4 To calculate fuel moisture and wind speeds associated with the ERC 
values, click Calculate (1).

5 To calculate an ERC and SC (Spread Component) from the fuel moisture 
and wind speed values, click Calculate (2).

6 To obtain a table and a printable report, click Done (3).

The following diagram shows the Percentile Weather for RERAP report.
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Appendix B. Using FireFamily Plus with rerap FireFamily Plus User’s Guide
For more information about RERAP, refer to "RERAP-Rare Event Risk 
Assessment Process User's Guide" at:  http://www.fs.fed.us/fire/rerap/ 
indexz.htm. This report can be imported directly into RERAP.
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Appendix C.  Editing “unknown” fire reporting 
units

This appendix explains how to add missing subunits to your FireFamily Plus 
template database. Once you complete this task, every subsequent database 
that you create will display these subunits.

Using a generic region/unit/subunit internal structure, FireFamily Plus blends 
fire data based on the different organizational structures of each agency. Since 
many Forest Service Districts have been consolidated over the years (and in 
some cases impossible to track systematically), you may find that you need to 
add missing subunits to your FireFamily Plus template database.

The tasks in this appendix explain how to use Microsoft Access 2000 to edit a 
FireFamily Plus template database previously created in Microsoft Access 97. 
Exit FireFamily Plus before proceeding.

To open the template database

1 On the Start menu, point to Programs, and locate Microsoft Access.

2 In the Microsoft Access dialog box, click Open, and then double-click 
and browse to the appropriate file. The following diagram shows the 
Microsoft Access dialog box.

3 Open the FireFamily Plus folder.

This folder is usually located at “C:/ProgramFiles/FireFamilyPlus4.”

The following diagram shows the location of the template database.
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FireFamily Plus User’s Guide Appendix C. Editing “unknown” fire reporting units
4 In the Files of type box, select All Files, and then double-click 
ffplus4.mdb. The following dialog box will open.

5 Click Open.

6 Double-click FireSubunits.

The following diagram shows the MS Access 2000 Convert/Open Database 
dialog box.

This dialog box does not display if you use MS Access 97 to update your 
template database.
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The following diagram shows the “FireSubunits” table selected.

To add a subunit to the FireSubunits table - an example

This task explains how to add the missing subunit “38,” district “07 Woodsey 
RD” to the last row “666” on the FireSubunits table.

1 Scroll down until you display the appropriate districts for your area, then 
review the FireSubunits Table and determine if there are any missing 
subunits. Write down the Unit ID that pertains to any missing subunits.

2 Scroll down to the last entry in the FireSubunits Table.

3 In the * (asterisk) row, click in the SubunitID column, and then type the 
next sequential number in the table.  

Watch for zeroes (0) that may be inadvertently inserted in the table! For 
example, be sure to type “666,” not “6660.”

4 In the UnitID column, type the unit identifier.

5 In the Name column, type the name of the missing subunit.

6 To save and exit the FireSubunits Table, click Exit on the File menu.
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The following diagram shows the FireSubunits Table. Notice the missing 
subunit on the Boise National Forest.
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The following diagram shows the new subunit added to the end of the 
FireSubunits Table.

This example shows you how to change the template database. To import 
new fire occurrence data, you must create a new database from the modified 
template database.

You can also modify an existing working database in the same manner, but 
you must re-import the fire occurrence data again to update the fires in the 
existing database. More than likely, these fires were rejected during the 
previous import process due to invalid subunits.
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Appendix D.  Weather data sources

There are two standard formats for extracting fire weather observations from 
the National Interagency Fire Management Integrated Database (NIFMID) - 
the older FWX (Wxobs72) and the newer FW9 (Wxobs98) formats. There are 
now also other sources of these data. The table below explains the data 
sources and the attributes of the different sources. The 3rd format, the DAT 
format from the WRCC data lister is an unedited listing of hourly sensor 
values which FireFamily Plus tries to interpret and ingest based on header 
lines embedded in the file. It is currently the only source for wind gust data.

1 Y2K (compliant). FireFamily Plus uses a pivot year of 29. That is, when 
reading a 2-digit year, 00 through 29 is considered 2000 to 2029. Values 
of 30 to 99 are considered 1930 to 1999.

2 Hourly Data. Hourly data are available from RAWS stations. FAMWEB-
KCFAST holds the last 18 months of hourly data for RAWS stations. The 
WRCC contains the period of record for RAWS stations, but only the 
sensor data - it does not have 'touched' data such as wet flag or state of the 
weather. Nor does it have daily or 24 hour summaries (i.e. 24 hour 
rainfall).

1FAMWEB - Fire and Weather Data. http://fam.nwcg.gov/fam-web/weatherfirecd/

2 NIFMID. National Interagency Fire Management Integrated Database. http://fam.nwcg.gov/fam-web/kcfast/mnmenu.htm, Login ID and password required. The 
NIFMID database contains the entire period of record (POR) for a station. In many cases this is from the mid-1950's.

3WRCC - Western Region Climate Center, RAWS Data Lister. http://www.raws.dri.edu/index.html. The WRCC database contains observations only from RAWS 

stations transmitting through the GOES satellite system. The earliest date of these records in generally the late 1970's.

4CEFA-FPA. Desert Research Institute's Climate, Ecosystem and Fire Applications Program that performed RAWS Quality Control for the Interagency Fire Program 
Analysis (FPA). http://www.wrcc.dri.edu/fpa/. This dataset has a limited POR, generally from the mid 1980's through 2004.
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3 NFDR “O/R.” By default the FWX formatted observation is a once-daily 
(1300) NFDR fire weather observation. The FW9 format allows for “O” 
and “R” type observations. The FW9 “O” observation should also have a 
valid state of the weather code. WRCC climate data lister files may have 
the “O” designation at 1300 local time but will not have a valid state of 
the weather code (it is blank). FireFamily Plus will interpret the blank to 
be zero (0). Non “O” type records are typed “R” (for Raws).

4 State of the weather (SOW). This is an ocular assessment of the sky 
conditions at the observing station used to indicate the amount of cloud 
cover, kind of precipitation, and/or restrictions to visibility at the fire-
danger station at observation time. Within the NFDRS processor, the 
SOW is used to establish the ground/fuel level temperature and relative 
humidity at the weather station. These values are then used in the dead 
fuel moisture calculations. It also established some “values by rule” as 
noted in the table below.

5 Wet Flag.   This entry is used in the operational NFDRS to indicate when 
the fuels are wet at observation time. The Wet Flag is automatically set to 
“Y” by the danger-rating processor if State of Weather (SOW) code “5”, 
“6”, or “7” is entered and causes the “values by rule” noted in the State of 
Weather table above.

Both year round and seasonal stations should consider snow covered fuels. As 
long as the fuels have snow on them, the Wet Flag is set to Y regardless of the 
SOW. 

With the wet flag set to Y in the snow-covered fuel scenario (SOW = 0,1,2,3,4 
or SOW = 8 or 9), the NFDRS processor considers the maximum and 
minimum relative humidity to be 100 percent (a no drying situation) 
regardless of the ambient relative humidity. This will invoke the “values by 

D R
 A

 F T
June, 2009 D.2
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rule” of the wet flag setting. In addition this can be particularly important for 
spring snow events because the NFDRS processor will model snowmelt 
following the snow as noted in the following table as long as the wet flag 
remain on. This keeps the 1000 hr-time lag fuel moistures at more 
representative values of fuels covered with snow or melting snow. 

6 Solar Radiation Data. This value is used to compute hourly fuel 
moisture with the Nelson dead fuel moisture model.

7 Gust Data. RAWS stations record maximum wind gust and direction for 
the hour in addition to the 10-minute average wind that is reported to 
NFDRS. These data are only available from the WRCC. Their inclusion 
in the FireFamily Plus database allows frequency distributions of 10-
minute averaged, or gusts to be used when creating fire-risk tables. 

8 NWS Station ID. WIMS and NIFMID use a 6 digit station ID, that at one 
time was issued by the National Weather Service. There is some 
“intelligence” in the numbering system. The first two digits was the state 
code, the second two the county code, and the third two the sequential 
station number in that count. These codes do not follow standard FIPS 
codes and does not work in states with more than 99 counties. The WRCC 
uses an internal station ID that is not related in anyway to the NWS 
station id. FireFamily Plus 4 has an internal cross reference that, when 
importing a data file from WRCC, will attempt to map a station id from 
the WRCC to the NWS Station ID. This cross reference is based on a 
spreadsheet from CEFA developed during their FPA-RAWS quality 
control work. If a match is found it will use to WRCC ID to identify the 
station but automatically use the station metadata from the associated 
NWS Station ID.D R
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