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FireFamilyPlus: Frequently Asked Questions 
The list of questions below are the most common questions we have received over time. If you have further questions, 
please contact the IIA Help Desk.  

Phone: 866-224-7677, 616-323-1667 
Website: https://iiahelpdesk.nwcg.gov 
Email and Chat available through the website. 
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General 

1. Which version of the US National Fire Danger Rating System is the “current” version? 
NFDRS v4 is the current version of the US National Fire Danger Rating System. The models for this version were 
developed and released in 2016, while software development took longer to develop. 
The versions of the US NFDRS are outlined as follows: 
• NFDRS v1: Released in 1972, this was the first release of a national fire danger rating system in the US. 
• NFDRS v2: Released in 1978, this version provided an update to v1. Outputs (ERC, SC, BI, IC) published in 1978 

are calculated in the same way today. 
• NFDRS v3: Released in 1988, this version modified v2 to account for humid areas such as the southeastern US. 

Minor modifications were made to some of the fuel models at the same time. 
• NFDRS v4: Released in 2016, v4 changed the calculation of both the dead and live fuel moisture, reduced the 

number of fuel models to 5, and ___. Calculation of the outputs remain the same as in v2. 

2. How do I install the latest version of FireFamilyPlus? 
Installation of FireFamilyPlus varies by agency. Contact your local IT personnel for assistance. 

Databases 

3. Why is my database blank? 
Ensure that you did not select File > New. If you did, the database was overwritten and cannot be recovered. 
If you select Fire > Open, the database crashed and it was blank when you reopened FireFamilyPlus, you may be able 
to get it back. Go to the folder where the database is located. If there is a *.ldb file associated with the database file, 
make sure FireFamilyPlus is closed and delete only the *.ldb file. This may restore the database. If not, save a backup 
of the file (zip) and review the next question. 

4. My database crashed, and when I try to open it, FF+ closes immediately. What now? 
See the previous question, if that does not work, you can try this solution.  
Do not try to open FireFamilyPlus again. Instead, you should edit your registry. Click on the Windows Start menu and 
immediately start typing Registry Editor. It should show up as the Best Match. Click on the Registry Editor App. USFS 
computers do not currently require administrative privileges to edit the registry. USE CAUTION WHEN EDITING 
ANYTHING IN THE REGISTRY EDITOR.  
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When the Registry Editor is open, use the folder structure on the left-hand side to navigate to Computer > 
HKEY_CURRENT_USER > SOFTWARE > FireFamilyPlus5 > FireFamily Plus > Recent File List. It should look similar to 
the image below. 

 
Highlight the files named File1 through File4. Right-click on them and select Delete. Click Yes on the warning window. 
When you are finished, there should be a single file: (Default). 
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When you are finished, close the Registry Editor. Then open FireFamilyPlus, navigate to the database, and try to open 
it. If this does not work, contact the Help Desk for assistance. 

5. What is the size limit for a FireFamilyPlus database? 
The current size limit for a FireFamilyPlus database is 1 GB. Files larger than this can generate increasingly nonsensical 
outputs. Compacting the database often decreases its size temporarily. However, if you are working with a number of 
weather stations, you may need to delete unused/older data or create multiple databases. For example, you can 
create a database for each Fire Assignment or for each Fire Danger Rating Area (FDRA) when developing a Fire 
Danger Operating Plan (FDOP). 

6. How do I save a backup of my FireFamilyPlus database? 
The easiest way to save a backup of your database is to create a zip file. Ensure that the database is closed. Right-click 
on the database and select Send to > Compressed (zipped) folder. Do this every time you make major changes to the 
database to ensure you always have a recent copy. 

7. Why is my database running so slowly? 
There are a number of reasons why the database is running slowly, including updates to Windows, the size of the 
database, and the amount of data being processed (particularly when initially calculating dead fuel moisture values). 
Try compacting the database. If this does not help, you may need to decrease the size of the database (see Question 
3). See the Troubleshooting Guide for more information. 

Input Data 

8. Who will have a FireFamilyPlus database for us when we show up on an incident? 
Contact the local Fire Planner or Dispatch Center Manager to see if they have an updated database. Otherwise, you 
will need to create a database on your own. 

9. Can I download weather from WFDSS for use in FireFamilyPlus? How do I do that? 
For the latest information about downloading weather data, obtain the latest Job Aids and review Job Aid 4. If this 
Job Aid is inaccurate, please contact the IIA Help Desk (information at end of document).  
Weather from the Wildland Fire Decision Support System (WFDSS) cannot easily be downloaded and put into 
FireFamilyPlus. You can download a daily FWX file from FSPro, but you cannot specify the data filter; all available data 
for the station are downloaded. This file must be modified to include only relevant information and imported as 
generic weather data as outlined in Job Aid 4. 

10. Where can I find station catalogs? 
While station catalog data can be found in WIMS, a station catalog formatted for direct input into FireFamilyPlus can 
be downloaded from the Data Warehouse (see Job Aid 4). 

11. Where do I go to get weather data? 
There are a number of sources of weather data. See Job Aid 4 for details. Most of these sites provide data in either 
the FW13 or FW21 format that can be readily imported into FireFamilyPlus. 

12. Should I download FW13 or FW21 weather files? 
You can download either format.  
• FW21 is the newest format and contains only the data required for NFDRS v4.  
• If you want to use NFDRS v2 or v3, you will need to download data in the FW13 format. 

13. Where do I go to get fire data? 
There are also a number of places to get fire data. The most recent is InFORM. You must obtain a NIFC account and 
request access to InFORM. See the website for more information. Job Aid 5 contains information about additional fire 
data sources. 

https://wfdss.usgs.gov/wfdss/WFDSS_Home.shtml
https://in-form-nifc.hub.arcgis.com/
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14. How do I add new fire data? 
See Job Aid 5 for the latest information on fire data. To import custom fire data, see Job Aid 10. 

15. How often should I update the data? 
Updating data depends on how you are using the data. For some people, updating the data once/year is enough. 
Others are updating it weekly, or even daily. There isn’t a “correct” answer to this question. 

16. How do I set the snow flags in FireFamilyPlus? How accurate are these snow flags? 
The Snow Flags in FireFamilyPlus are brought in with the data from other sources. If there are no data, it will be left 
blank. The data themselves are only as good as their source. Data in WIMS are manually input. Data from the CEFA 
website (soon to be turned off), contain snow flags that were manually created. It is always good to check data 
quality, including snow flags. 
To set snow flags in FireFamilyPlus, use the following steps. 
• Click on Options > Snow Flag. 
• You can select either Set by Filter or Set Hourly from Daily. 

 
a. Select Set Hourly from Daily to use the Snow Flag reported at 1300 by WIMS to fill in the values for the 

remaining 23-hours per day.   
• Click on Options > Snow Flag > Set Hourly from Daily. 
• In the Fill Hourly Snow Flag window, select a Station and click Apply. 

 
A FireFamilyPlus window appears verifying that you want to proceed with this change. Click on Yes or No. 
The process can take some time. 
Tip: All data are processed; you cannot select a given time frame. 

 
• When it is finished, select another weather station, or click Close. 

b. Set by Filter allows you to set the Snow Flag for a period of time for a given station. 
• Click on Options > Snow Flag > Set by Filter. 
• In the Snow Flag Management window, select a Station. The station must have data, and you can only select 

one station at a time. 
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• Select a Snow Flag Value: A Snow Flag of 0 indicates there is no snow, while a Snow Flag of 1 indicates snow
is present.

• Identify the Years to modify: The first and last year of data are shown once you select a station.
• Select an Annual Filter (Time of Year). If you want to enter data for the winter months, you will need to add

snow flags for the beginning of the year (e.g., January-February) and end of the year (e.g., December)
separately. FireFamilyPlus will only change the data within the selected Working Set.

• Click Apply to set the snow flags or Close to close the window.

• Once you click Apply, a verification window will appear. Select Yes to change the snow flags or No to close
the window without changing them.

• A summary of the changes is shown. Click OK to return to the Snow Flag Management window.

Note: Once the snow flags have been modified, you will need to recalculate the dead fuel moisture and fuel 
temperature values for the time period. You do not have to do this immediately; it will be done automatically 
the next time you create a Stats Graph or other output. 

• Modify the settings for another time period or station or click Close to exit the Snow Flag Management
window.

Calculations 
17. How often do I need to compact? What happens if I don’t?

Compacting the database deletes temporary data and removes blank lines within the dataset. For large databases,
best practice is to compact the database one ore more times/day if you are doing a large number of analyses or your
database is large.

18. Can we change the GSI values used for our area?
Yes, but care is needed when selecting values. Select values that match seasonal greenup and curing in your area.
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19. What is a batch file used for? 
A batch file allows you to pre-program a series of analyses that you do regularly. For example, you may want to 
create daily Stats Graphs for an area. You can set up FireFamilyPlus to do this. As you import new data, you can run 
the batch file and receive Stats Graphs with updated data. However, FireFamilyPlus is currently unable to download 
and import weather data automatically. You will need to do that first. 

20. What is the difference between a batch file and Interactive Batch? 
While a batch file is a pre-programmed set of outputs that you create, Interactive Batch automatically creates most of 
the reports, graphs, and analyses available for a selected weather station or SIG. You can select multiple weather 
stations or SIGs at a time. Results are created for the weather data, US NFDRS outputs and Canadian outputs. Simply 
find the output of interest and view the results.  

21. I used Event Locator to populate the Term file. What do I need to know?  
Set up an Event Locator session with the established season slowing/ending conditions. Once the Event Locator file 
has been created, click on Options > Add to Term. Note: The first event that matches your criteria will be added to 
the term file. This may or may not represent the end of your fire season, so chose the time period carefully or exam 
the Event Locator data yourself. 

 

Working Set Window 
22. When do I need to select “Force NFDRS Recompute”? 

If you have made significant changes to existing weather data for a weather station, you will need to check the box 
next to Force NFDRS Recompute. If you are adding new data to the dataset, you do not need to force a recompute.  
Perhaps the easiest way to recompute the data is to create a Stats Graph (e.g., ERC-Y). Once the Stats Graph has been 
created, uncheck the box next to Force NFDRS Recompute and continue your calculations. 

23. What happened to “Enable Auxiliary Years Overlay”? 
Because of the confusion it caused, Enable Auxiliary Years Overlay was removed in 2023. Calculations are now made 
for all weather data included in the Station or SIG, regardless of the Working Set. This allows users to add overlays at 
any point during their analysis. See Question 25 for possible issues. 

NFDRS Outputs 

24. Why is the Y-axis so long? All the lines are crammed at the bottom of the graph. 
We recently removed the checkbox for Enable Auxiliary Years. FireFamilyPlus now calculates the fire danger for all of 
the data in the file so that you can overlay any year in the dataset on a graph without rerunning it. If the lines are not 
taking up the entire graph, there is an erroneous datapoint somewhere in the database but outside of your current 
working set. Search the input data to find the error, delete it, and try again. Look for the data point prior to 
contacting the help desk. It is there. 
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25. How do I export weather data? 
Weather data are exported via the Observations window. 

• Click on Weather > View Observations and then either Daily or All or select the shortcut icons:  for daily and 
 for all observations. 

• There are three options in the upper left corner of the Observations table. You can save (  ), print (  ), or 
delete (  ) observations.  

• Observations can be exported as FW9 (deprecated), FW13, FW21, FlamMap/FARSITE Stream, or Custom 
Format.  
• The first four options have pre-determined formats.  

• Export FW13 Format allows you to select between Hourly Precipitation and 24 Hour Precipitation.  
• FlamMap/FARSITE Stream allows you to select Winds that are either Ten minute avg. or Gusts. 

• If you select Custom Format, you can select from all available fields. Change the output format as desired 
(e.g., change Field Delimiter to Comma for ease of use). 

 

26. How do I export fire data? 

View the fire data by going to Fire data Fires > Summary. Select either Working Set (  ) or General. For Working 
Set, you must have specified Fire Associations for the Station or SIG. General allows you to identify any fire 
associations you would like as well as the years to display. Selections in General do not affect the Working Set in any 
way. 
• Click on Fires Summary and select either Working Set or General. 
• In the Select Fires for Summary for… window, select the Agencies, Regions, Units, and Sub Units as desired. 
• Click on View Fires. 

There are three options in the upper left corner of the Observations table. You can save (  ), print (  ), or delete 
(  ) observations. 
• To export data, click on the Save button. 
• Identify the Selected Fields and export the data using Export text file or Export ESRI shapefile (shp/shx/dbf).  

• When using Export text file, set preferences for the file on the right. For best results, select Comma for Field 
Delimiter. 

• Export ESRI shapefile has a defined format. Make sure to include the Latitude and Longitude. 
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27. How do I export Stats Graph data? 
Sometimes you want to export data from a graph for use in other software.  
• Create a Stats Graph for the variable(s) of interest. 
• Click on File > Export Graph Data. 
• Delete any lines of text above variable names. 
• Delete the line of dashes between the variable names and the data. 
The final data (example below) can be imported into Excel for graphing. 

 

Other Fire Danger Products 

28. What is the latest FEMS news, and what does that mean for FireFamilyPlus users? 
To find out the latest news about the Fire Environment Mapping System (FEMS), visit their website or sign up for 
their quarterly newsletter. Once FEMS 1.0 is operational, FireFamilyPlus users should be able to go to a single 
location for easily downloadable historical weather data, which includes gap-filled data, if desired. FireFamilyPlus will 
continue to be available for off-line use, including training. Outputs from both systems should be identical. 

29. What is the 8–14-day Climate Prediction Center NFDRS product? Explain how it works. 
This product is not developed by the US Forest Service, and as such the developers of FireFamilyPlus are not 
responsible for its maintenance. Based on our research, the Climate Prediction Center (CPC) produces a Fire-weather 
Week 2 (8-14 Day) Forecast. The outputs are identified, as with other CPC products, by terciles (ranked and divided 
into thirds identified as Below, Average, and Above).  Below indicates those values that are < 33.333% of the 
climatological average, while Above indicates those values > 66.667% of climatology.  
Climatology is based on data from the ECMWF ERA-5 reanalysis data for 2000-2019, These data were used to create 
Climate Normals. Work for this product was done by researchers at the University of Colorado Boulder, and 
NOAA/ESRL, Physical Sciences Laboratory in Boulder, Colorado. Read the journal articles by Worsnop et al (2020, 
2021; links on the website) or contact the developers to understand how it was developed.  

https://www.wildfire.gov/application/fems
https://www.wildfire.gov/page/fems-newsletters
https://www.wildfire.gov/page/fems-newsletters
https://www.cpc.ncep.noaa.gov/products/people/mchen/fireWeather/cpc_wk2fw_index.html
https://www.cpc.ncep.noaa.gov/products/people/mchen/fireWeather/cpc_wk2fw_index.html
https://www.ecmwf.int/en/forecasts/dataset/ecmwf-reanalysis-v5
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